cocoon-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Giacomo Pati <giac...@apache.org>
Subject Re: [BUG] MailAction requires JDK 1.4
Date Tue, 07 Jan 2003 23:58:09 GMT
On Wed, 8 Jan 2003, Bernhard Huber wrote:

> hi,
>
> Carsten Ziegeler wrote:
> > Hi,
> >
> > the latest addition to the scratchpad, e.g. the MailAction
> > required a JDK 1.4 (because of StringBuffer.indexOf).
> > Please change this asap.
> >
> i have corrected the sources to be javac 1.3 compileable,
> i have compiled it locally using JDK 1.3
>
> hope it is fixed,
> sorry for the inconvienience,
>
> now compilation depends "only" on existance of mail.jar and activation.jar.

Next, will have to make it compile only if mail.jar is present (as we do
with other parts, ie. POI, Axis).

> i'm waiting if it is okay to put mail.jar and activation.jar into
> lib/optional due to license issues,

It compiles on my side.

> btw, mail.jar version 1.3 is required for compiling and running.

Giacomo


---------------------------------------------------------------------
To unsubscribe, e-mail: cocoon-dev-unsubscribe@xml.apache.org
For additional commands, email: cocoon-dev-help@xml.apache.org


Mime
View raw message