cocoon-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Carsten Ziegeler" <cziege...@s-und-n.de>
Subject RE: [CVS] - 2.1 problem with caching in authentication
Date Thu, 16 Jan 2003 08:10:04 GMT
Hi Antonio,

after the latest changes from yesterday, I currently don't experience
any problem (although of course I can't test 100%).

Is it possible to strip down your example and sent it in the list,
so that we can reproduce the problem - this would really help in
finding the source of the bug.
Or if anyone else is having similar problems, perhaps he can sent
an example (as short as possible please).

Yesterday, Marcus helped in finding one bug in the newer caching
implementation because he could point to a cocoon sample (the
flow calculator demo) which wasn't running anymore. So, if you
find an example that does not work for you, we can reproduce
the problem as well.

I will do some more tests today, but I fear that I can't reproduce the
problem.

I guess, that the bug is introduced by the new caching implementation.
You can try this by turning of caching in the sitemap.

Thanks for your help
Carsten

Carsten Ziegeler
Open Source Group, S&N AG


Antonio Gallardo wrote:
>
> Hi Carsten:
>
> I was today working again trying to discover where is the root of the
> problem without results. And after all the day trying all the posibilities
> I imaginate. I got to the conclusion that there must be something wrong
> that must be patched. Recently there is a mail from Ivelin that can
> confirm my conclusion. He is suspecting about the Xalan and Xerces. I am
> suspecting about
>
> excalibur-sourceresolve-20030109.jar
>
> or another of the new libraries.
>
> Please dont ask me why. It is just based on my intuition or perceptions of
> the changes.
>
> I tried all the posibilities, including the total new download of the CVS.
>
> My application works fine with any version prior 11-Jan-2003. And after
> some changes in the CVS, it is imposible to get it run. I have the
> compiled version of the Cocoon CVS 2.1 from 10-Jan-2003 and with it the
> application works.
>
> I will stay checking if there are some improvements and trying to get it
> work.
>
> By my experience in the mailist it may take sometime until it will be
> fixed. unfortunatelly I have no big experience in checking the Cocoon
> code. Of course I buyed all the books about Cocoon. Your book is the only
> ones I have right now on hand. The other two are in the road. I am
> waiting.
>
> By the way, I forgot to mention my development environment: ;-)
>
> Athlon 1.6GHz., 512 MB RAM, 60 GB HD.
> Red Hat Linux 8.0 (lastest patches)
> Tomcat 4.1.18
> J2SDK 1.4.1_01
> PostgreSQL 7.2.3
> Cocoon 2.1 (lastest CVS).
>
> please check comments below:
>
> Best Regards,
>
> Antonio Gallardo



---------------------------------------------------------------------
To unsubscribe, e-mail: cocoon-dev-unsubscribe@xml.apache.org
For additional commands, email: cocoon-dev-help@xml.apache.org


Mime
View raw message