cocoon-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Carsten Ziegeler" <>
Subject RE: [RT]: Names for pipeline components section
Date Mon, 13 Jan 2003 10:01:04 GMT
Stefano Mazzocchi wrote:
> >>map:generator    generate
> >>map:transformer  transform
> >>...              ...               ...
> >>map:pipe     pipeline
> > 
> > 
> > Is this a real problem? I've never thought about such relationship.
> > Anybody else?
> Well, if somebody thinks it is a problem we can change the java 
> classname with much less user pain.
The classes and interfaces are new for 2.1, so changing them is absolutely

Having a weekend for thinking about the naming problem, I think Stefano
is right, that map:pipe (= a verb) is not a good choice to use for the
pipelines section (= the section where pipelines are defined).

So, I agree (now) that we should rename the components section from
map:pipeline to map:pipe.

Anyone against this? If not I can rename them tomorrow.


To unsubscribe, e-mail:
For additional commands, email:

View raw message