cocoon-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Nicola Ken Barozzi <>
Subject Re: [RT]: Names for pipeline components section
Date Fri, 10 Jan 2003 13:55:38 GMT

Carsten Ziegeler wrote:
> Giacomo Pati wrote:
>>On Fri, 10 Jan 2003, Carsten Ziegeler wrote:
>>>We currently have two sections named map:pipelines and map:pipeline in
>>>the sitemap (2.1). As we all know from experience this is absolutely
>>>confusing and wasn't a good naming idea (my fault).
>>>I think Sylvain and Michael have already suggested new names, but
>>>I can't remember them and I'm too lazy to search the mail archives :)
>>>We need a new and simple name for the components section:
>>>  <map:pipelines default="caching">
>>>    <map:pipeline .../>
>>>  ...
>>What about simply map:pipe[s]?
> Yes, why not - if noone comes up with a better name, we will use that.

I'd prefer to keep the current naming instead of that one.

For consistency it would be map:pipeline in the components, and map:pipe 
in the "beefy" part.

  pipeline generator transformer ...
  pipe     generate  transform   ...

Inverting it is not so cool IMHO. I haven't yet seen users complain it's 
not understandable and I've never had that problem myself.

Nicola Ken Barozzi         
             - verba volant, scripta manent -
    (discussions get forgotten, just code remains)

To unsubscribe, e-mail:
For additional commands, email:

View raw message