cocoon-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Stefano Mazzocchi <stef...@apache.org>
Subject Re: Wrap-up for flow functions [WAS Re: Changes made to flow system.js]
Date Thu, 09 Jan 2003 19:28:22 GMT
Ovidiu Predescu wrote:
> I'd like to start working on the control flow documentation ASAP and I 
> was wondering what is the status on the naming convention proposal I 
> made a while ago.
> 
> So far I've counted three +1 votes for reverting back to the old naming 
> convention and providing the following aliases:
> 
> sendPage <=> sendPageAndWait (this function provides the blocking 
> functionality, the response is sent, the continuation captured and the 
> script execution stops)
> 
> sendPageAndContinue <=> sendPageNoWait (this function sends the response 
> and continues the script execution)

I'm against aliases as well.

I'd say let's go for the new terminology and let's stick with that once 
and forever.

People can do a find/replace for now but at least they won't find 
scripts with all four methods floating around the internet.

-- 
Stefano Mazzocchi                               <stefano@apache.org>
--------------------------------------------------------------------



---------------------------------------------------------------------
To unsubscribe, e-mail: cocoon-dev-unsubscribe@xml.apache.org
For additional commands, email: cocoon-dev-help@xml.apache.org


Mime
View raw message