cocoon-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Antonio Gallardo" <agalla...@agsoftware.dnsalias.com>
Subject RE: [CVS] - 2.1 problem with caching in authentication
Date Wed, 15 Jan 2003 00:03:48 GMT
Hi Carsten!

I am going crazy with the new error. Please help :-).

Today morning I downloaded the updates from the CVS. After the updates,
the problem was moved to another part of the code. I was all the day
trying to get this up without results. :-(

Now I got this error in the same place:

DEBUG   (2003-01-14) 17:12.17:170   [core.authentication-manager]
(/myapp/aut-inicio) Thread-7/AuthenticationManager: BEGIN isAuthenticated
handler=myhandler

DEBUG   (2003-01-14) 17:12.17:170   [core.authentication-manager]
(/myapp/aut-inicio) Thread-7/AuthenticationManager: END isAuthenticated
authenticated=false

ERROR   (2003-01-14) 17:12.17:171   [core.manager] (/myapp/aut-inicio)
Thread-7/ExcaliburComponentSelector: UnnamedSelector: ComponentSelector
Attempted to retrieve component with null hint.

DEBUG   (2003-01-14) 17:12.17:187   [core.manager] (/myapp/aut-inicio)
Thread-7/ExcaliburComponentManager: Could not find component for role:
org.apache.cocoon.components.notification.NotifyingBuilder

ERROR   (2003-01-14) 17:12.17:203   [core.manager] (/myapp/aut-inicio)
Thread-7/ExcaliburComponentSelector: UnnamedSelector: ComponentSelector
Attempted to retrieve component with null hint.

WARN    (2003-01-14) 17:12.17:206   [core.manager] (/myapp/aut-inicio)
Thread-7/ExcaliburComponentSelector: Attempted to release a null
component.

WARN    (2003-01-14) 17:12.17:206   [core.manager] (/myapp/aut-inicio)
Thread-7/ExcaliburComponentSelector: Attempted to release a null
component.

The sitemap worked fine with the CVS 2.1 from 2003-1-10. In the sitemap is:

<map:match pattern="aut-inicio">
  <map:act type="auth-loggedIn">
    <map:parameter name="handler" value="agshandler"/>
      <map:redirect-to uri="bienvenidos"/>
  </map:act>
  <map:generate src="docs/aut-inicio.xsp" type="serverpages"/>
  <map:transform src="stylesheets/agssa.xsl"/>
  <map:transform type="encodeURL"/>
  <map:serialize/>
</map:match>

Now the interesting is the docs/aut-inicio.xsp file:

<xsp:page xmlns:xsp="http://apache.org/xsp">
<document menu="false">
  <permiso>publico</permiso>
  <header>
    <title>Sistema de Canje de Multipremios</title>
  </header>
  <t1 title="Verificación de Usuario">
    <loginform>
      <url resource="bienvenidos">ags-login</url>
      <field name="name" type="text" size="24"
        theTag="User" help="Write the username"/>
      <field name="password" type="password" size="10"
        theTag="Password" help="Write the password"/>
    </loginform>
  </t1>
  <note>Please write your username and password</note>
</document>
</xsp:page>

Please tell me some advise to get this stuff back to work again.

Best Regards,

Antonio Gallardo



Carsten Ziegeler dijo:
> Hi Antonio,
>
> can you have a look in the logs for the real place of the NPE?
> In line 470 in the AuthenticationManager the NPE is only rethrown.
>
> Carsten
>
>> -----Original Message-----
>> From: Antonio Gallardo [mailto:agallardo@agsoftware.dnsalias.com]
>> Sent: Monday, January 13, 2003 8:38 PM
>> To: cocoon-dev@xml.apache.org
>> Subject: Re: [CVS] - 2.1 problem with caching in authentication
>>
>>
>> Hi, I give update info about the problem I saw:
>>
>> The error is a java.lang.NullPointerException:
>>
>> ERROR (2003-01-13) 13:18.44:110 [core.authentication-manager]
>> (/demo/my-login) Thread-12/AuthenticationManager: authenticate
>> org.apache.cocoon.ProcessingException: Could not get sitemap source
>> cocoon://my-checkuser?password=mypassword&name=myname:
>> java.lang.NullPointerException at
>> org.apache.cocoon.webapps.authentication.components.Authentication
>> Manager.authenticate(AuthenticationManager.java:470)
>>
>> This code works fine until the update this morning. The my-checkuser
>> is redirected as usually and is a XSP page that get from the database
>> the users from a table.
>>
>> Please tell me what changed that I dont get this code work again. :-(
>>
>> Best Regards,
>>
>> Antonio Gallardo
>>
>> Antonio Gallardo dijo:
>> > Hi!
>> >
>> > I downloaded just 10 mins before the lastes CVS version and I have a
>> problem with the following code that before worked OK:
>> >
>> > <map:match pattern="auth-checkuser">
>> >   <map:generate src="docs/get-users.xsp" type="serverpages"/>
>> >   <map:transform src="stylesheets/get-users.xsl">
>> >     <map:parameter name="use-request-parameters" value="true"/>
>> >   </map:transform>
>> >   <map:serialize type="xml"/>
>> > </map:match>
>> >
>> > I think the problem is related to the line:
>> >
>> > <map:parameter name="use-request-parameters" value="true"/>
>> >
>> > because in the sitemap.log i saw:
>> >
>> > DEBUG   (2003-01-13) 11:23.31:958   [sitemap.transformer.xsltc]
>> (/multipremios/my-login) Thread-6/TraxTransformer: Use parameters is
>> false for org.apache.cocoon.transformation.TraxTransformer@1950e0a
>> >
>> >
>> > Is changed the <map:parameter> tag?
>> >
>> > Please, help me.
>> >
>> > Regards,
>> >
>> > Antonio Gallardo
>> >
>> >
>> >
>> >
>> >
>> > ---------------------------------------------------------------------
>> To unsubscribe, e-mail: cocoon-dev-unsubscribe@xml.apache.org
>> > For additional commands, email: cocoon-dev-help@xml.apache.org
>>
>>
>>
>>
>> ---------------------------------------------------------------------
>> To unsubscribe, e-mail: cocoon-dev-unsubscribe@xml.apache.org
>> For additional commands, email: cocoon-dev-help@xml.apache.org
>>
>
>
> --------------------------------------------------------------------- To
> unsubscribe, e-mail: cocoon-dev-unsubscribe@xml.apache.org
> For additional commands, email: cocoon-dev-help@xml.apache.org




---------------------------------------------------------------------
To unsubscribe, e-mail: cocoon-dev-unsubscribe@xml.apache.org
For additional commands, email: cocoon-dev-help@xml.apache.org


Mime
View raw message