cocoon-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From bugzi...@apache.org
Subject DO NOT REPLY [Bug 16246] - [PATCH]EncodeURLTransformer, rewriting doesn't work when session created by XSP
Date Sun, 26 Jan 2003 15:04:42 GMT
DO NOT REPLY TO THIS EMAIL, BUT PLEASE POST YOUR BUG 
RELATED COMMENTS THROUGH THE WEB INTERFACE AVAILABLE AT
<http://nagoya.apache.org/bugzilla/show_bug.cgi?id=16246>.
ANY REPLY MADE TO THIS MESSAGE WILL NOT BE COLLECTED AND 
INSERTED IN THE BUG DATABASE.

http://nagoya.apache.org/bugzilla/show_bug.cgi?id=16246

[PATCH]EncodeURLTransformer, rewriting doesn't work when session created by XSP

m_rolappe@web.de changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
             Status|RESOLVED                    |REOPENED
         Resolution|WORKSFORME                  |



------- Additional Comments From m_rolappe@web.de  2003-01-26 15:04 -------
well, it neither works in 2.0.4 nor 2.1 for me.

and I can't see how it could work when using xsp:session's create-
session="true" or own <xsp:logic> (except overriding the setup() method for 
this generator); the pipeline and its components are setup before generation 
begins. that means when EncodeURLTransformer's setup() method is called the 
XSP's generate() and thus request.getSession(true) havent't been called and no 
session was created.

maybe you have the session created somewhere else or are using cookies?

anyway, I'll attach a test file besides a test sitemap. in the generated html 
page, the link is not url-encoded.

---------------------------------------------------------------------
To unsubscribe, e-mail: cocoon-dev-unsubscribe@xml.apache.org
For additional commands, email: cocoon-dev-help@xml.apache.org


Mime
View raw message