cocoon-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Sam Ruby <ru...@us.ibm.com>
Subject [GUMP] Build Failure - xml-cocoon2
Date Wed, 08 Jan 2003 13:12:08 GMT
----------------------------------------------------
This email is autogenerated from the output from:
<http://cvs.apache.org/builds/gump/2003-01-08/xml-cocoon2.html>
----------------------------------------------------

Buildfile: build.xml

init:
     [echo] --------------------------------------------------------------
     [echo]             Apache Cocoon 20030108 [1999-2002]                  
     [echo] --------------------------------------------------------------
     [echo] Building with Apache Ant version 1.6alpha compiled on January 8 2003
     [echo] using build file /home/rubys/jakarta/xml-cocoon2/build.xml
     [echo] --------------------------------------------------------------
     [echo]  WARNING:                                                     
     [echo]    This build is targeted for use with JVM 1.4
     [echo]                                                               
     [echo]    Using this build on a virtual machine other than the one   
     [echo]    it is targeted for may result in runtime errors.          
     [echo]                                                               
     [echo] --------------------------------------------------------------
  [taskdef] dropping /home/rubys/jakarta/jakarta-slide/dist/slide/lib/slide-kernel.jar from
path as it doesn't exist
  [taskdef] dropping /home/rubys/php/lib/php/phpsrvlt.jar from path as it doesn't exist
  [taskdef] dropping /home/rubys/jakarta/xml-cocoon2/build/cocoon/classes from path as it
doesn't exist
  [taskdef] dropping /home/rubys/jakarta/xml-cocoon2/tools/anttasks from path as it doesn't
exist
  [taskdef] Could not load definitions from resource net/sf/antcontrib/antcontrib.properties.
It could not be found.
    [mkdir] Created dir: /home/rubys/jakarta/xml-cocoon2/tools/anttasks
    [javac] Compiling 2 source files to /home/rubys/jakarta/xml-cocoon2/tools/anttasks
    [javac] 9 warnings

optional-tests:
     [echo] Testing for optional components

bsf-warn:

op-warning:
     [echo] **********************************************
     [echo] *
     [echo] *  Classes of the optional package BSF are not 
     [echo] *  available. Apache Cocoon builds without them.
     [echo] *
     [echo] *  BSF is required for the script action.
     [echo] *
     [echo] *  Recovery:
     [echo] *  Get the BSF package from http://oss.software.ibm.com/developerworks/projects/bsf/
and place the jar in the lib/optional dir
     [echo] *
     [echo] ***********************************************

rhino-warn:

jfor-warn:

op-warning:
     [echo] **********************************************
     [echo] *
     [echo] *  Classes of the optional package JFOR are not 
     [echo] *  available. Apache Cocoon builds without them.
     [echo] *
     [echo] *  JFOR is required for the fo2rtf serializer.
     [echo] *
     [echo] *  Recovery:
     [echo] *  Get the JFOR package from http://www.jfor.org/ and place the jar in the lib/optional
dir
     [echo] *
     [echo] ***********************************************

xmldb-warn:

php-warn:

op-warning:
     [echo] **********************************************
     [echo] *
     [echo] *  Classes of the optional package PHP are not 
     [echo] *  available. Apache Cocoon builds without them.
     [echo] *
     [echo] *  PHP is required for the php generator.
     [echo] *
     [echo] *  Recovery:
     [echo] *  Get the PHP servlet (phpsrvlt.jar) from http://www.php.net/ and place the jar
in the lib/optional dir
     [echo] *
     [echo] ***********************************************

naming-warn:

svg-warn:

op-warning:
     [echo] **********************************************
     [echo] *
     [echo] *  Classes of the optional package Batik are not 
     [echo] *  available. Apache Cocoon builds without them.
     [echo] *
     [echo] *  Batik is required for the svg serializers.
     [echo] *
     [echo] *  Recovery:
     [echo] *  Get Batik from http://xml.apache.org/batik/ and place the jar in the lib/optional
dir
     [echo] *
     [echo] ***********************************************

tidy-warn:

op-warning:
     [echo] **********************************************
     [echo] *
     [echo] *  Classes of the optional package JTidy are not 
     [echo] *  available. Apache Cocoon builds without them.
     [echo] *
     [echo] *  JTidy is required for the html generator.
     [echo] *
     [echo] *  Recovery:
     [echo] *  Get JTidy from http://sourceforge.net/projects/jtidy/ and place the jar in
the lib/optional dir
     [echo] *
     [echo] ***********************************************

maybeupload-warn:

lucene-warn:

op-warning:
     [echo] **********************************************
     [echo] *
     [echo] *  Classes of the optional package Lucene are not 
     [echo] *  available. Apache Cocoon builds without them.
     [echo] *
     [echo] *  Lucene is required for the Cocoon searches.
     [echo] *
     [echo] *  Recovery:
     [echo] *  Get Lucene from http://jakarta.apache.org/lucene/ and place the jar in the
lib/optional dir
     [echo] *
     [echo] ***********************************************

deli-warn:

velocity-warn:

op-warning:
     [echo] **********************************************
     [echo] *
     [echo] *  Classes of the optional package Velocity are not 
     [echo] *  available. Apache Cocoon builds without them.
     [echo] *
     [echo] *  Velocity is required for the velocity generator.
     [echo] *
     [echo] *  Recovery:
     [echo] *  Get Velocity from http://jakarta.apache.org/velocity/ and place the jar in
the lib/optional dir
     [echo] *
     [echo] ***********************************************

hsqldb-warn:

op-warning:
     [echo] **********************************************
     [echo] *
     [echo] *  Classes of the optional package hsqldb are not 
     [echo] *  available. Apache Cocoon builds without them.
     [echo] *
     [echo] *  hsqldb is required for the sql examples.
     [echo] *
     [echo] *  Recovery:
     [echo] *  Get hsqldb from http://hsqldb.sourceforge.net/ and place the jar in the lib/optional
dir
     [echo] *
     [echo] ***********************************************

resolver-warn:

jisp-warn:

pizza-warn:

poi-warn:

op-warning:
     [echo] **********************************************
     [echo] *
     [echo] *  Classes of the optional package POI are not 
     [echo] *  available. Apache Cocoon builds without them.
     [echo] *
     [echo] *  POI is required for the POI sitemap components.
     [echo] *
     [echo] *  Recovery:
     [echo] *  Get the POI package from http://jakarta.apache.org/poi/ and place the jar in
the lib/optional dir
     [echo] *
     [echo] ***********************************************

commons-logging-warn:

op-warning:
     [echo] **********************************************
     [echo] *
     [echo] *  Classes of the optional package Jakarta Commons Logging are not 
     [echo] *  available. Apache Cocoon builds without them.
     [echo] *
     [echo] *  The Jakarta Commons Logging package is required for the POI sitemap components.
     [echo] *
     [echo] *  Recovery:
     [echo] *  Get the Jakarta Commons Logging package from http://jakarta.apache.org/commons/logging/
and place the jar in the lib/optional dir
     [echo] *
     [echo] ***********************************************

jxpath-warn:

httpclient-warn:

activation-warn:

op-warning:
     [echo] **********************************************
     [echo] *
     [echo] *  Classes of the optional package Activation are not 
     [echo] *  available. Apache Cocoon builds without them.
     [echo] *
     [echo] *  The SUN Activation package is required for the AxisRPCReader class
     [echo] *
     [echo] *  Recovery:
     [echo] *  Get the SUN Activation package and place the jar in the lib/local dir
     [echo] *
     [echo] ***********************************************

transaction-warn:

op-warning:
     [echo] **********************************************
     [echo] *
     [echo] *  Classes of the optional package Transaction are not 
     [echo] *  available. Apache Cocoon builds without them.
     [echo] *
     [echo] *  The SUN Java Transaction package is required for the Slide classes
     [echo] *
     [echo] *  Recovery:
     [echo] *  Get the SUN Java Transaction package and place the jar in the lib/local dir
     [echo] *
     [echo] ***********************************************

optional-warnings:

prepare:
    [mkdir] Created dir: /home/rubys/jakarta/xml-cocoon2/build/cocoon

compile:
     [xslt] Processing /home/rubys/jakarta/xml-cocoon2/project-info.xml to /home/rubys/jakarta/xml-cocoon2/build/cocoon/work/blocks-build.xml
     [xslt] Loading stylesheet /home/rubys/jakarta/xml-cocoon2/tools/src/blocks-build.xsl
      [ant] No object referenced by mocks.dirs. Can't copy to mocks.dirs
Caught exception (org.apache.tools.ant.BuildException) while expanding jar.files: /home/rubys/jakarta/xml-cocoon2/build/cocoon/webapp/WEB-INF/lib
not found.
      [ant] No object referenced by jar.files. Can't copy to jar.files
      [ant] No object referenced by libs. Can't copy to libs
      [ant] No object referenced by src.dirs. Can't copy to src.dirs
      [ant] No object referenced by all.jars. Can't copy to all.jars

cocoon-core:

init:
     [echo] --------------------------------------------------------------
     [echo]             Apache Cocoon 20030108 [1999-2002]                  
     [echo] --------------------------------------------------------------
     [echo] Building with Apache Ant version 1.6alpha compiled on January 8 2003
     [echo] using build file /home/rubys/jakarta/xml-cocoon2/build.xml
     [echo] --------------------------------------------------------------
     [echo]  WARNING:                                                     
     [echo]    This build is targeted for use with JVM 1.4
     [echo]                                                               
     [echo]    Using this build on a virtual machine other than the one   
     [echo]    it is targeted for may result in runtime errors.          
     [echo]                                                               
     [echo] --------------------------------------------------------------
  [taskdef] dropping /home/rubys/jakarta/jakarta-slide/dist/slide/lib/slide-kernel.jar from
path as it doesn't exist
  [taskdef] dropping /home/rubys/php/lib/php/phpsrvlt.jar from path as it doesn't exist
  [taskdef] dropping /home/rubys/jakarta/xml-cocoon2/build/cocoon/classes from path as it
doesn't exist
  [taskdef] Could not load definitions from resource net/sf/antcontrib/antcontrib.properties.
It could not be found.

optional-tests:
     [echo] Testing for optional components

bsf-warn:

op-warning:
     [echo] **********************************************
     [echo] *
     [echo] *  Classes of the optional package BSF are not 
     [echo] *  available. Apache Cocoon builds without them.
     [echo] *
     [echo] *  BSF is required for the script action.
     [echo] *
     [echo] *  Recovery:
     [echo] *  Get the BSF package from http://oss.software.ibm.com/developerworks/projects/bsf/
and place the jar in the lib/optional dir
     [echo] *
     [echo] ***********************************************

rhino-warn:

jfor-warn:

op-warning:
     [echo] **********************************************
     [echo] *
     [echo] *  Classes of the optional package JFOR are not 
     [echo] *  available. Apache Cocoon builds without them.
     [echo] *
     [echo] *  JFOR is required for the fo2rtf serializer.
     [echo] *
     [echo] *  Recovery:
     [echo] *  Get the JFOR package from http://www.jfor.org/ and place the jar in the lib/optional
dir
     [echo] *
     [echo] ***********************************************

xmldb-warn:

php-warn:

op-warning:
     [echo] **********************************************
     [echo] *
     [echo] *  Classes of the optional package PHP are not 
     [echo] *  available. Apache Cocoon builds without them.
     [echo] *
     [echo] *  PHP is required for the php generator.
     [echo] *
     [echo] *  Recovery:
     [echo] *  Get the PHP servlet (phpsrvlt.jar) from http://www.php.net/ and place the jar
in the lib/optional dir
     [echo] *
     [echo] ***********************************************

naming-warn:

svg-warn:

op-warning:
     [echo] **********************************************
     [echo] *
     [echo] *  Classes of the optional package Batik are not 
     [echo] *  available. Apache Cocoon builds without them.
     [echo] *
     [echo] *  Batik is required for the svg serializers.
     [echo] *
     [echo] *  Recovery:
     [echo] *  Get Batik from http://xml.apache.org/batik/ and place the jar in the lib/optional
dir
     [echo] *
     [echo] ***********************************************

tidy-warn:

op-warning:
     [echo] **********************************************
     [echo] *
     [echo] *  Classes of the optional package JTidy are not 
     [echo] *  available. Apache Cocoon builds without them.
     [echo] *
     [echo] *  JTidy is required for the html generator.
     [echo] *
     [echo] *  Recovery:
     [echo] *  Get JTidy from http://sourceforge.net/projects/jtidy/ and place the jar in
the lib/optional dir
     [echo] *
     [echo] ***********************************************

maybeupload-warn:

lucene-warn:

op-warning:
     [echo] **********************************************
     [echo] *
     [echo] *  Classes of the optional package Lucene are not 
     [echo] *  available. Apache Cocoon builds without them.
     [echo] *
     [echo] *  Lucene is required for the Cocoon searches.
     [echo] *
     [echo] *  Recovery:
     [echo] *  Get Lucene from http://jakarta.apache.org/lucene/ and place the jar in the
lib/optional dir
     [echo] *
     [echo] ***********************************************

deli-warn:

velocity-warn:

op-warning:
     [echo] **********************************************
     [echo] *
     [echo] *  Classes of the optional package Velocity are not 
     [echo] *  available. Apache Cocoon builds without them.
     [echo] *
     [echo] *  Velocity is required for the velocity generator.
     [echo] *
     [echo] *  Recovery:
     [echo] *  Get Velocity from http://jakarta.apache.org/velocity/ and place the jar in
the lib/optional dir
     [echo] *
     [echo] ***********************************************

hsqldb-warn:

op-warning:
     [echo] **********************************************
     [echo] *
     [echo] *  Classes of the optional package hsqldb are not 
     [echo] *  available. Apache Cocoon builds without them.
     [echo] *
     [echo] *  hsqldb is required for the sql examples.
     [echo] *
     [echo] *  Recovery:
     [echo] *  Get hsqldb from http://hsqldb.sourceforge.net/ and place the jar in the lib/optional
dir
     [echo] *
     [echo] ***********************************************

resolver-warn:

jisp-warn:

pizza-warn:

poi-warn:

op-warning:
     [echo] **********************************************
     [echo] *
     [echo] *  Classes of the optional package POI are not 
     [echo] *  available. Apache Cocoon builds without them.
     [echo] *
     [echo] *  POI is required for the POI sitemap components.
     [echo] *
     [echo] *  Recovery:
     [echo] *  Get the POI package from http://jakarta.apache.org/poi/ and place the jar in
the lib/optional dir
     [echo] *
     [echo] ***********************************************

commons-logging-warn:

op-warning:
     [echo] **********************************************
     [echo] *
     [echo] *  Classes of the optional package Jakarta Commons Logging are not 
     [echo] *  available. Apache Cocoon builds without them.
     [echo] *
     [echo] *  The Jakarta Commons Logging package is required for the POI sitemap components.
     [echo] *
     [echo] *  Recovery:
     [echo] *  Get the Jakarta Commons Logging package from http://jakarta.apache.org/commons/logging/
and place the jar in the lib/optional dir
     [echo] *
     [echo] ***********************************************

jxpath-warn:

httpclient-warn:

activation-warn:

op-warning:
     [echo] **********************************************
     [echo] *
     [echo] *  Classes of the optional package Activation are not 
     [echo] *  available. Apache Cocoon builds without them.
     [echo] *
     [echo] *  The SUN Activation package is required for the AxisRPCReader class
     [echo] *
     [echo] *  Recovery:
     [echo] *  Get the SUN Activation package and place the jar in the lib/local dir
     [echo] *
     [echo] ***********************************************

transaction-warn:

op-warning:
     [echo] **********************************************
     [echo] *
     [echo] *  Classes of the optional package Transaction are not 
     [echo] *  available. Apache Cocoon builds without them.
     [echo] *
     [echo] *  The SUN Java Transaction package is required for the Slide classes
     [echo] *
     [echo] *  Recovery:
     [echo] *  Get the SUN Java Transaction package and place the jar in the lib/local dir
     [echo] *
     [echo] ***********************************************

optional-warnings:

prepare:

generate-java-code-check:

generate-java-code:
     [xslt] Transforming into /home/rubys/jakarta/xml-cocoon2/build/cocoon/src/org/apache/cocoon/components/browser
     [xslt] Processing /home/rubys/jakarta/xml-cocoon2/src/java/org/apache/cocoon/components/browser/BrowserImpl.xml
to /home/rubys/jakarta/xml-cocoon2/build/cocoon/src/org/apache/cocoon/components/browser/BrowserImpl.java
     [xslt] Loading stylesheet /home/rubys/jakarta/xml-cocoon2/src/java/org/apache/cocoon/components/browser/BrowserImpl.xsl

-copy-deprecated-stuff2core:
     [copy] Copying 55 files to /home/rubys/jakarta/xml-cocoon2/build/cocoon/src

prepare-src-main:
    [mkdir] Created dir: /home/rubys/jakarta/xml-cocoon2/build/cocoon/classes
     [copy] Copying 579 files to /home/rubys/jakarta/xml-cocoon2/build/cocoon/src
     [copy] Replacing: @name@ -> Apache Cocoon
     [copy] Replacing: @version@ -> 20030108
     [copy] Replacing: @year@ -> 1999-2002

BUILD FAILED
file:///home/rubys/jakarta/xml-cocoon2/build.xml:988: Could not create task or type of type:
if.

Ant could not find the task or a class this task relies upon.

This is common and has a number of causes; the usual 
solutions are to read the manual pages then download and
install needed JAR files, or fix the build file: 
 - You have misspelt 'if'.
   Fix: check your spelling.
 - The task needs an external JAR file to execute
   and this is not found at the right place in the classpath.
   Fix: check the documentation for dependencies.
   Fix: declare the task.
 - The task is an Ant optional task and optional.jar is absent
   Fix: look for optional.jar in ANT_HOME/lib, download if needed
 - The task was not built into optional.jar as dependent
   libraries were not found at build time.
   Fix: look in the JAR to verify, then rebuild with the needed
   libraries, or download a release version from apache.org
 - The build file was written for a later version of Ant
   Fix: upgrade to at least the latest release version of Ant
 - The task is not an Ant core or optional task 
   and needs to be declared using <taskdef>.

Remember that for JAR files to be visible to Ant tasks implemented
in ANT_HOME/lib, the files must be in the same directory or on the
classpath

Please neither file bug reports on this problem, nor email the
Ant mailing lists, until all of these causes have been explored,
as this is not an Ant bug.

Total time: 21 seconds

---------------------------------------------------------------------
To unsubscribe, e-mail: cocoon-dev-unsubscribe@xml.apache.org
For additional commands, email: cocoon-dev-help@xml.apache.org


Mime
View raw message