cocoon-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Litrik De Roy" <cocoon-...@litrik.com>
Subject Re: build : no more optional compilation, new eclipse-project target
Date Thu, 02 Jan 2003 21:06:45 GMT
----- Original Message -----
From: "Sylvain Wallez" <sylvain.wallez@anyware-tech.com>
To: <cocoon-dev@xml.apache.org>
Sent: Thursday, January 02, 2003 12:09 PM
Subject: build : no more optional compilation, new eclipse-project target


> Hi folks,
>
> I just commited some changes to the build system :
...
> - there's a new "eclipse-project" build target that creates the Eclipse
> project files for Cocoon.
>
> Sylvain
>

Sylvain,

The .classpath file generated by the eclipse-project seems to be missing the
following entry:

<classpathentry path="tools/lib/ant-1.5.jar" kind="lib"/>

Without it, the scratchpad won't build and the following error is generated:

Error   The import org.apache.tools cannot be resolved CocoonTask.java
Cocoon 2.1-dev/src/scratchpad/src/org/apache/cocoon/ant line 77

PS: Or it could be me...I'm still struggling trying to build Cocoon inside
Eclipse...

Litrik De Roy
www.litrik.com



---------------------------------------------------------------------
To unsubscribe, e-mail: cocoon-dev-unsubscribe@xml.apache.org
For additional commands, email: cocoon-dev-help@xml.apache.org


Mime
View raw message