cocoon-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Ovidiu Predescu <ovi...@apache.org>
Subject Re: Changes made to flow system.js
Date Wed, 04 Dec 2002 16:24:59 GMT

On Wednesday, Dec 4, 2002, at 06:30 US/Pacific, Michael Melhem wrote:

> On Wed, Dec 04, 2002 at 02:56:50PM +0100, Sylvain Wallez wrote:
>> Michael Melhem wrote:
>>
>>> On Wed, Dec 04, 2002 at 02:19:33PM +0100, Sylvain Wallez wrote:
>>>
>>>
>>>> Marcus Crafter wrote:
>>>>
>>>> Just some thoughts (sorry if this already has been discussed, I may 
>>>> have
>>>> missed it) : why not keeping the "sendPageAndContinue" ?
>>>>
>>>>
>>>
>>> sendPageAndContinue is precisely the problem, many people were
>>> confusing "Continue" with continuations!
>>>
>>>
>>
>> Ah, ok, I understand... but I'm still uncomfortable with having a
>> precise "sendPageAndWait" and an imprecise "sendPage", as inconsistent
>> naming always leads to confusion.
>
> Yes I know what you mean. hmmm...

I agree, I was thinking about exactly this last night.

>> So, last try : what about "sendPageAndReturn" ?
>
> This name was already suggested, but Ovidiu had some objection to 
> "Return". ???

People usually associate "return" with returning from the current 
function. I'm still looking for a better name to mean the function 
sends the response page, but continues the processing of the script 
without creating a continuation and stopping. I personally still prefer 
the sendPageAndContinue, now that we have sendPageAndWait it should be 
clear the meaning of "Continue".

> BTW, are you coming to the Stammtisch too? ;)

I don't know about Sylvain, but I'm still thinking about it ;)

Ovidiu


---------------------------------------------------------------------
To unsubscribe, e-mail: cocoon-dev-unsubscribe@xml.apache.org
For additional commands, email: cocoon-dev-help@xml.apache.org


Mime
View raw message