cocoon-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Ovidiu Predescu <ovi...@apache.org>
Subject Re: Changes made to flow system.js
Date Thu, 05 Dec 2002 07:47:51 GMT

On Wednesday, Dec 4, 2002, at 13:11 US/Pacific, Jason Foster wrote:

> <snip/>
>
> How about thinking in terms of synchronous and asynchronous I/O?
>
> sendPageAndBlock() or sendPageSync()
> sendPageAsync()

On Wednesday, Dec 4, 2002, at 14:33 US/Pacific, Andy Lewis wrote:

>
> what about I/O terms?
>
> sendPageBlocking
> sendPageNonBlocking
>
> or something akin to these?

I think the danger is to have the semantics of these functions 
associated with the way the response page is actually sent over the 
wire.

To reiterate my option, I think sendPageAndWait and sendPageAndContinue 
are still the best options. They also provide the maximum compatibility 
with the old naming, only sendPage dissapears, everything else is the 
same.

Regards,
Ovidiu


---------------------------------------------------------------------
To unsubscribe, e-mail: cocoon-dev-unsubscribe@xml.apache.org
For additional commands, email: cocoon-dev-help@xml.apache.org


Mime
View raw message