cocoon-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Matteo Di Giovinazzo <matte...@infinito.it>
Subject Re: Changes made to flow system.js
Date Thu, 05 Dec 2002 22:13:13 GMT
Stefano Mazzocchi wrote:
> Andy Lewis wrote:
> 
>> what about I/O terms?
>>
>> sendPageBlocking
>> sendPageNonBlocking
> 
> 
> I still like the concept of "waiting" a lot more. In short, your 
> 'server' is waiting for you to come back. It would be like having your 
> personal thread allocated in the server, even if this is not the case.
> 
> The best I could think of would be:
> 
> sendPageAndHaveYourServerWaitForYouToComeBack
> sendPageAndSetYourServerFreeToServeSomebodyElse
> 
> :-D
> 
> but of course I'm not proposing these method names :-)
> 
> now, somebody with good english skills should srink those concepts down 
> to a reasonable short sentence.
> 


What do you think of these method names?

sendPageAndBack()
sendPageAndWait()



CIAO!

-- 
matteodg = |keip|

    <http://unipdleague.sourceforge.net/>
      Fantacalcio Università di Padova



---------------------------------------------------------------------
To unsubscribe, e-mail: cocoon-dev-unsubscribe@xml.apache.org
For additional commands, email: cocoon-dev-help@xml.apache.org


Mime
View raw message