cocoon-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Sylvain Wallez <>
Subject Re: Changes made to flow system.js
Date Thu, 05 Dec 2002 08:29:23 GMT
Ovidiu Predescu wrote:

> On Wednesday, Dec 4, 2002, at 13:11 US/Pacific, Jason Foster wrote:
>> <snip/>
>> How about thinking in terms of synchronous and asynchronous I/O?
>> sendPageAndBlock() or sendPageSync()
>> sendPageAsync()
> On Wednesday, Dec 4, 2002, at 14:33 US/Pacific, Andy Lewis wrote:
>> what about I/O terms?
>> sendPageBlocking
>> sendPageNonBlocking
>> or something akin to these?
> I think the danger is to have the semantics of these functions 
> associated with the way the response page is actually sent over the wire.
> To reiterate my option, I think sendPageAndWait and 
> sendPageAndContinue are still the best options. They also provide the 
> maximum compatibility with the old naming, only sendPage dissapears, 
> everything else is the same.

Agree. I think the confusion of "sendPageAndContinue" with continuations 
came from the fact that the "sendPage" counterpart wasn't semantically 
precise enough.

Most people seem to agree that "sendPageAndWait" is a good name. My 
english skills tell me that "continue" is a good word as a complementary 
to "wait". And since my skills are somewhat limited, it's likely that it 
most people will have the same understanding as me :)

So, IMO, "sendPageAndWait" and "sendPageAndContinue", are good names, 
being equally-precise and semantically complementary.


Sylvain Wallez                                  Anyware Technologies 
{ XML, Java, Cocoon, OpenSource }*{ Training, Consulting, Projects }

To unsubscribe, e-mail:
For additional commands, email:

View raw message