cocoon-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Sylvain Wallez <sylvain.wal...@anyware-tech.com>
Subject Re: Changes made to flow system.js
Date Wed, 04 Dec 2002 13:56:50 GMT
Michael Melhem wrote:

>On Wed, Dec 04, 2002 at 02:19:33PM +0100, Sylvain Wallez wrote:
>  
>
>>Marcus Crafter wrote:
>>
>>>Hi Troops!
>>>
>>>	Hope all is well.
>>>	
>>>	I've just checked in BZ#14903 which changes the names of the flow 
>>>	sendPage* functions as previously discussed in the 'flow wishlist' 
>>>	thread.
>>>	
>>>	Unfortunately the change is *not* backwards compatible so please be 
>>>	careful and update any flow code you might have locally after 
>>>	updating.
>>>	
>>>	The changes are:
>>>	
>>>	sendPage() becomes sendPageAndWait()
>>>	sendPageAndContinue() becomes sendPage()
>>>	
>>>	The last one is the tricky one because the method names are 
>>>	essentially swapped.
>>>
>>>      
>>>
>>Just some thoughts (sorry if this already has been discussed, I may have 
>>missed it) : why not keeping the "sendPageAndContinue" ?
>>    
>>
>
>sendPageAndContinue is precisely the problem, many people were 
>confusing "Continue" with continuations!
>  
>

Ah, ok, I understand... but I'm still uncomfortable with having a 
precise "sendPageAndWait" and an imprecise "sendPage", as inconsistent 
naming always leads to confusion.

So, last try : what about "sendPageAndReturn" ?

Sylvain

-- 
Sylvain Wallez                                  Anyware Technologies
http://www.apache.org/~sylvain           http://www.anyware-tech.com
{ XML, Java, Cocoon, OpenSource }*{ Training, Consulting, Projects }



---------------------------------------------------------------------
To unsubscribe, e-mail: cocoon-dev-unsubscribe@xml.apache.org
For additional commands, email: cocoon-dev-help@xml.apache.org


Mime
View raw message