cocoon-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Sylvain Wallez <>
Subject Re: Changes made to flow system.js
Date Wed, 04 Dec 2002 13:19:33 GMT
Marcus Crafter wrote:

>Hi Troops!
>	Hope all is well.
>	I've just checked in BZ#14903 which changes the names of the flow sendPage* functions
as previously discussed in the 'flow wishlist' thread.
>	Unfortunately the change is *not* backwards compatible so please be careful and update
any flow code you might have locally after updating.
>	The changes are:
>	sendPage() becomes sendPageAndWait()
>	sendPageAndContinue() becomes sendPage()
>	The last one is the tricky one because the method names are essentially swapped.

Just some thoughts (sorry if this already has been discussed, I may have 
missed it) : why not keeping the "sendPageAndContinue" ?

This would remove any ambiguity that may be attached to the somewhat 
imprecise "sendPage".


Sylvain Wallez                                  Anyware Technologies 
{ XML, Java, Cocoon, OpenSource }*{ Training, Consulting, Projects }

To unsubscribe, e-mail:
For additional commands, email:

View raw message