cocoon-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Christian Haul <h...@dvs1.informatik.tu-darmstadt.de>
Subject Re: Changes made to flow system.js
Date Mon, 09 Dec 2002 08:38:22 GMT
On 08.Dec.2002 -- 03:48 PM, Stefano Mazzocchi wrote:
> Hmmmm, hmmm, hmmm, ok, ok, what about something radically different like
> 
>  getUserInputFromScreen(uri)
> 
> to replace sendPageAndWait()?

Only that this function returns void which is again misleading. I
would expect a function named "get...." to return a value.

I'm all with Christopher: revert to "sendPage" and have some ugly name
for the special case where no continuation is created. But then we are
back to start :-(

Splitting it up like Marc suggested would be another option only that
95% will write their own wrapper around this since the natural use is
all three together (create id + send page + create continuation). OTOH
there would be interesting uses if one could slip in code between
create id and send page.

Of course we could split it up and provide a convenience function.

	Chris.
-- 
C h r i s t i a n       H a u l
haul@informatik.tu-darmstadt.de
    fingerprint: 99B0 1D9D 7919 644A 4837  7D73 FEF9 6856 335A 9E08

---------------------------------------------------------------------
To unsubscribe, e-mail: cocoon-dev-unsubscribe@xml.apache.org
For additional commands, email: cocoon-dev-help@xml.apache.org


Mime
View raw message