cocoon-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Nicola Ken Barozzi <nicola...@apache.org>
Subject Re: [ PHPGenerator ] Inital draft of PHPGenerator docs on Wiki
Date Tue, 12 Nov 2002 08:13:51 GMT

Tony Collen wrote:
> http://outerthought.net/wiki/Wiki.jsp?page=PHPGenerator
> 
[...]
> On a side note (to -dev), why is it "PhpGenerator" and not 
> "PHPGenerator"?  We have HTTPGenerator and SWFGenerator, so perhaps the 
> file should be renamed to PHPGenerator for consistency's sake?

Changing a name of a class just for consistency brings us a small 
advantage (consistency) and a big damage (broken classes and refs 
depending on it).

In this case it may be not a problem as for classes depending on it, but 
I woulodn't like to be the sitemap guy that goes round fixing all the 
declarations in the sitemaps ;-)

-- 
Nicola Ken Barozzi                   nicolaken@apache.org
             - verba volant, scripta manent -
    (discussions get forgotten, just code remains)
---------------------------------------------------------------------


---------------------------------------------------------------------
To unsubscribe, e-mail: cocoon-dev-unsubscribe@xml.apache.org
For additional commands, email: cocoon-dev-help@xml.apache.org


Mime
View raw message