cocoon-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From bugzi...@apache.org
Subject DO NOT REPLY [Bug 14452] New: - Adding a J2EE data source does not work
Date Mon, 11 Nov 2002 17:28:57 GMT
DO NOT REPLY TO THIS EMAIL, BUT PLEASE POST YOUR BUG 
RELATED COMMENTS THROUGH THE WEB INTERFACE AVAILABLE AT
<http://nagoya.apache.org/bugzilla/show_bug.cgi?id=14452>.
ANY REPLY MADE TO THIS MESSAGE WILL NOT BE COLLECTED AND 
INSERTED IN THE BUG DATABASE.

http://nagoya.apache.org/bugzilla/show_bug.cgi?id=14452

Adding a J2EE data source does not work

           Summary: Adding a J2EE data source does not work
           Product: Cocoon 2
           Version: Current CVS
          Platform: Other
        OS/Version: Other
            Status: NEW
          Severity: Normal
          Priority: Other
         Component: general components
        AssignedTo: cocoon-dev@xml.apache.org
        ReportedBy: mb@blumenstrasse.vol.at


Versions: 2.0.4dev from CVS (NOT 2.1dev)
Tomcat 4.1.12
JDK 1.4.1, Linux


I add the following to server.xml in TOMCAT_HOME/conf:
...
<Resource name="jdbc/lpedit" scope="Shareable" type="javax.sql.DataSource"/>
  <ResourceParams name="jdbc/test">
    <parameter>
      <name>url</name>
      <value>jdbc:postgresql://localhost/test</value>
    </parameter>
    ...
  </ResourceParams>
...          
This data source works, I tested it (but not in the cocoon context).


I add the following to cocoon.xconf:
...
<j2ee name="testpool">
<dbname>test</dbname>
</j2ee>
...
</datasources>

Now I get:
Error in sitemap configuration : Could not set up Component for hint: add-employee

<dbname>jdbc/test</dbname> does not work either.

---------------------------------------------------------------------
To unsubscribe, e-mail: cocoon-dev-unsubscribe@xml.apache.org
For additional commands, email: cocoon-dev-help@xml.apache.org


Mime
View raw message