cocoon-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Stephan Michels <step...@apache.org>
Subject Re: Getting rid of deprecated Interfaces/Classes/Methods
Date Tue, 24 Sep 2002 16:39:17 GMT


On Tue, 24 Sep 2002, Vadim Gritsenko wrote:

> Carsten Ziegeler wrote:
>
> >Giacomo Pati wrote:
> >
> >
> >>Hi Team
> >>
> >>I'll have some spare time this week and thought of moving the HEAD branch
> >>away from deprecated stuff from newest Avalon Framework/Excalibur jars.
> >>
> >>My plan will be:
> >>
> >>   1.  Get rid of Loggable in favor of LogEnabled
> >>   2.  Get rid of Component and move to Service infrastructure
> >>
> >>1. is straight forward and doesn't need any voting I think
> >>
> >>
> >>
> >Yupp. +1
> >

I get also rid of the deprecated classes, so +1.

> +1. Some of this work is done already, by Stefan (IIRC).

Do you mean Stefano, or do you mean moi(Stephan)?

For some time ago, I tried to replace also the deprecated LogKitManageable
classes, but the Avalon people don't want to apply my patch :-/

http://issues.apache.org/bugzilla/show_bug.cgi?id=11491

>
> >>2. can be done in two steps:
> >>
> >>   a. move from Component to Service infrastructure as the
> >>ExcaliburComponentManager supports this.
> >>
> >>   b. use Fortress/Merlin (don't know the status of those and which one
> >>makes more sense for Cocoon to be used, so I need some advice of
> >>Avalonians here)
> >>
> >>
> >>
> >What does this mean in terms of compatibility and a stable Cocoon? Are
> >written components using a CM with Composable and Component still working?
> >I think noone will recode all the components he has written so far. But
> >I guess that this is covered.
> >
> >So the remaining question is, is fortress/merlin stable and usable?
> >If these both points can be answered positiv, I would say: +1.
> >
>
> -1 for 2.1. If you read this thread, you will see that the changes are
> too drastic to make this in 2.1, and it already has loads of changes by
> itself. This asks for at least 2.5, or even 3.0.

Couldn't we release the damn 2.1, and remove all the deprecated classes?
Then we will have enough room to migrate to Fortress/Merlin or whatever.

Stephan.


---------------------------------------------------------------------
To unsubscribe, e-mail: cocoon-dev-unsubscribe@xml.apache.org
For additional commands, email: cocoon-dev-help@xml.apache.org


Mime
View raw message