cocoon-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Ovidiu Predescu <>
Subject Re: [control flow] changes and new sample
Date Mon, 09 Sep 2002 04:48:18 GMT

On Sunday, September 8, 2002, at 01:57 PM, Sylvain Wallez wrote:

> Ovidiu Predescu wrote:
>> Stefano, Vadim,
>> On Saturday, September 7, 2002, at 10:09 PM, Ovidiu Predescu wrote:
>>> I remember this being discussed some time ago. I think the ability 
>>> to describe multiple flows in one sitemap is nothing else than FS. A 
>>> flow is usually associated with a complete application. Having 
>>> multiple flows is a complication which may makes things harder to 
>>> write and follow.
>>> What I'm instead working on is a simpler setup, like this:
>>> <map:flow language="JavaScript">
>>>   <map:script src="prefs.js"/>
>>>   <map:script src="some-other-script.js"/>
>>> </map:flow>
>>> The idea here is that we have a Cocoon Web application described in 
>>> the current sitemap, whose flow is described in multiple script 
>>> files. Again, make no mistake, flow in this context is not a simple 
>>> sequence of pages, but it describes the whole application. E.g. a 
>>> map:flow element describes all the scripts that compose the 
>>> Controller.
>> Actually I now realize that declaring flow scripts this way, 
>> interferes with Vadim's proposal on using <map:flow> to invoke a 
>> function or restart a continuation. Can we find a better name for 
>> <map:flow> in this context? I was thinking of <map:flow-resources>, 
>> but it's a bit too long for my taste. As an alternative how about 
>> <map:controller>?
> I like very much this <map:controller> as it's the name used 
> traditionnaly in the MVC pattern. Cocoon shouldn't invent a new word 
> (map:flow) to designate a well-known concept. MVC is much hyped and is 
> a "magic word" for many customers (see how many of them want Struts 
> because it's MVC).

Good point, Sylvain! Sticking with known names is going to help us in 
user acceptance as well.

> If we choose <map:controller>, then using <map:flow> to call this 
> controller doesn't sound well. Something like <map:call-controller> 
> sounds better, but you may find it a bit lengthy...
> Other thoughts ?

How about calling it simply <map:call> instead of <map:flow>? This is 
how is called today as well, but we need to modify its semantics to 
support Vadim's proposal, and to get rid of today's <map:continue>.

Ovidiu Predescu <> (Weblog) (Apache, GNU, 
Emacs ...)

To unsubscribe, e-mail:
For additional commands, email:

View raw message