cocoon-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Berin Loritsch <blorit...@apache.org>
Subject [heads-up] The version of ECM in CVS has a change in JDK reqs
Date Fri, 27 Sep 2002 20:54:48 GMT
One of the fundamental issues with the move from ComponentManager to
ServiceManager is what do we do with components that do not implement
the "Component" interface.  This is especially important because someone
removed the Component interface from the Monitor components in Excalibur
CVS.  The solution, believe it or not was already written, but ECM
didn't take advantage of it.

ECM now uses a sporty new utility called a ComponentProxyGenerator,
which requires JDK 1.3 or higher because it generates a Proxy for the
component that extends the component's role interface and the Component
interface.  As a result you can use the ComponentManager to access
legacy systems where you don't have access or privelege to change the
interface.  In the end this change is for the better.

As a result, if Cocoon wants to use the latest and greatest ECM, then
it must use JDK 1.3 or higher.  I am sure that JDK 1.3 will help make
some things easier to do in Cocoon.  Also note that should Cocoon use
the latest and greatest from Fortress (comming to a store near you RSN)
or Merlin, it would have to upgrade to JDK 1.3 or better anyway.

-- 

"They that give up essential liberty to obtain a little temporary safety
  deserve neither liberty nor safety."
                 - Benjamin Franklin


---------------------------------------------------------------------
To unsubscribe, e-mail: cocoon-dev-unsubscribe@xml.apache.org
For additional commands, email: cocoon-dev-help@xml.apache.org


Mime
View raw message