cocoon-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Sylvain Wallez <sylvain.wal...@anyware-tech.com>
Subject Re: [control flow] changes and new sample
Date Sun, 08 Sep 2002 20:57:06 GMT
Ovidiu Predescu wrote:

> Stefano, Vadim,
>
> On Saturday, September 7, 2002, at 10:09 PM, Ovidiu Predescu wrote:
>
>>> 2) is the 'flow' really a <map:resource>?
>>>
>>> I don't think so. A flow is a flow. This calls for a more explicit:
>>>
>>>  <map:flows default-language="javascript">
>>>   <map:flow name="prefs" src="prefs.js"/>
>>>   <map:flow name="something-else" src="something.scm"
>>> language="scheme"/>
>>>  </map:flows>
>>>
>>> which allows:
>>>
>>>  - to declare more scripts (this eases aggregation of different 
>>> webapps,
>>> will be useful for blocks)
>>>  - to map them to different interpreting engines based on their
>>> language.
>>
>>
>> I remember this being discussed some time ago. I think the ability to 
>> describe multiple flows in one sitemap is nothing else than FS. A 
>> flow is usually associated with a complete application. Having 
>> multiple flows is a complication which may makes things harder to 
>> write and follow.
>>
>> What I'm instead working on is a simpler setup, like this:
>>
>> <map:flow language="JavaScript">
>>   <map:script src="prefs.js"/>
>>   <map:script src="some-other-script.js"/>
>> </map:flow>
>>
>> The idea here is that we have a Cocoon Web application described in 
>> the current sitemap, whose flow is described in multiple script 
>> files. Again, make no mistake, flow in this context is not a simple 
>> sequence of pages, but it describes the whole application. E.g. a 
>> map:flow element describes all the scripts that compose the Controller.
>
>
> Actually I now realize that declaring flow scripts this way, 
> interferes with Vadim's proposal on using <map:flow> to invoke a 
> function or restart a continuation. Can we find a better name for 
> <map:flow> in this context? I was thinking of <map:flow-resources>, 
> but it's a bit too long for my taste. As an alternative how about 
> <map:controller>? 


I like very much this <map:controller> as it's the name used 
traditionnaly in the MVC pattern. Cocoon shouldn't invent a new word 
(map:flow) to designate a well-known concept. MVC is much hyped and is a 
"magic word" for many customers (see how many of them want Struts 
because it's MVC).

If we choose <map:controller>, then using <map:flow> to call this 
controller doesn't sound well. Something like <map:call-controller> 
sounds better, but you may find it a bit lengthy...

Other thoughts ?

<snipped what="single element proposal which I agree with"/>

Sylvain

-- 
Sylvain Wallez
 Anyware Technologies                  Apache Cocoon
 http://www.anyware-tech.com           mailto:sylvain@apache.org




---------------------------------------------------------------------
To unsubscribe, e-mail: cocoon-dev-unsubscribe@xml.apache.org
For additional commands, email: cocoon-dev-help@xml.apache.org


Mime
View raw message