cocoon-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Ovidiu Predescu <ovi...@apache.org>
Subject Re: [control flow] changes and new sample
Date Sun, 08 Sep 2002 07:54:36 GMT
Stefano, Vadim,

On Saturday, September 7, 2002, at 10:09 PM, Ovidiu Predescu wrote:

>> 2) is the 'flow' really a <map:resource>?
>>
>> I don't think so. A flow is a flow. This calls for a more explicit:
>>
>>  <map:flows default-language="javascript">
>>   <map:flow name="prefs" src="prefs.js"/>
>>   <map:flow name="something-else" src="something.scm"
>> language="scheme"/>
>>  </map:flows>
>>
>> which allows:
>>
>>  - to declare more scripts (this eases aggregation of different 
>> webapps,
>> will be useful for blocks)
>>  - to map them to different interpreting engines based on their
>> language.
>
> I remember this being discussed some time ago. I think the ability to 
> describe multiple flows in one sitemap is nothing else than FS. A flow 
> is usually associated with a complete application. Having multiple 
> flows is a complication which may makes things harder to write and 
> follow.
>
> What I'm instead working on is a simpler setup, like this:
>
> <map:flow language="JavaScript">
>   <map:script src="prefs.js"/>
>   <map:script src="some-other-script.js"/>
> </map:flow>
>
> The idea here is that we have a Cocoon Web application described in 
> the current sitemap, whose flow is described in multiple script files. 
> Again, make no mistake, flow in this context is not a simple sequence 
> of pages, but it describes the whole application. E.g. a map:flow 
> element describes all the scripts that compose the Controller.

Actually I now realize that declaring flow scripts this way, interferes 
with Vadim's proposal on using <map:flow> to invoke a function or 
restart a continuation. Can we find a better name for <map:flow> in 
this context? I was thinking of <map:flow-resources>, but it's a bit 
too long for my taste. As an alternative how about <map:controller>?

Again, Vadim's proposal in

http://marc.theaimsgroup.com/?l=xml-cocoon-dev&m=102454393731251&w=2,

is to replace the <map:call function="..."/> and <map:continue 
with="..."/> with a single <map:flow> element, which takes as 
attributes either "function", "continuation" or both. Based on what 
attributes and/or values are present, it functions either as restarting 
a computation stored in a continuation, or calls a new function.

Any thoughts?

Thanks,
-- 
Ovidiu Predescu <ovidiu@apache.org>
http://webweavertech.com/ovidiu/weblog/ (Weblog)
http://www.geocities.com/SiliconValley/Monitor/7464/ (Apache, GNU, 
Emacs ...)


---------------------------------------------------------------------
To unsubscribe, e-mail: cocoon-dev-unsubscribe@xml.apache.org
For additional commands, email: cocoon-dev-help@xml.apache.org


Mime
View raw message