cocoon-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Ivelin Ivanov" <ive...@apache.org>
Subject Re: XForms response to select1 vs. singleSelect
Date Wed, 28 Aug 2002 12:45:24 GMT

I thin I understand the difficulties of choosing the name.
I don't thing that picking select1 for HTML compatibility over selectOne,
which is in line with naming conventions in many languages, is justified.



----- Original Message -----
From: "Piroumian Konstantin" <KPiroumian@protek.com>
To: <cocoon-dev@xml.apache.org>
Sent: Wednesday, August 28, 2002 1:35 AM
Subject: FW: XForms response to select1 vs. singleSelect


> Below is the answer to my question about the select1 element naming in
> XForms specification.
>
> --
> Konstantin Piroumian
>
>
> > -----Original Message-----
> > From: Klotz, Leigh [mailto:Leigh.Klotz@pahv.xerox.com]
> > Sent: Wednesday, August 28, 2002 1:41 AM
> > To: 'Piroumian Konstantin'; 'www-forms-editor@w3.org'
> > Cc: Klotz, Leigh
> > Subject: XForms response to select1 vs. singleSelect
> >
> >
> > Thank you for your comments.
> >
> > I'd like to answer the issues you raise in your last message
> > (below) and ask
> > you a question.
> >
> > On <choose> and <choice>:
> > - Either would be confused with the "choices" element -- one might
> > reasonably believe that <choice> would always be a child element of
> > <choices>.
> > (Please see
> > http://www.w3.org/TR/xforms/slice8.html#ui-common-elements-choices)
> > - The pair of names "choice" and "select" doesn't really
> > indicate which is
> > used for a single selection and which is used for multiple choice.
> > (Or is it which is used for a single choice and which is used
> > for multiple
> > selection?)
> >
> > On the XHTML 2.0 issues raised:
> > - Public discussion of XHTML takes place on www-html@w3.org,
> > so you can ask
> > detailed questions about the h and section elements there.
> > - We consulted with the HTML WG Chair, and he recommended that we keep
> > <select> and <select1>.
> >
> > It's difficult to come up with names that fit all constraints and make
> > everyone happy.  Can you can live with the names in the current XForms
> > working draft?
> >
> > Thank you,
> > Leigh.
> >
> >
> >
> > -----Original Message-----
> > From: Piroumian Konstantin [mailto:KPiroumian@protek.com]
> > Sent: Tuesday, August 27, 2002 12:51 AM
> > To: 'Klotz, Leigh'; 'www-forms@w3.org'
> > Subject: RE: Naming: select1 vs. singleSelect
> >
> >
> > > From: Klotz, Leigh [mailto:Leigh.Klotz@pahv.xerox.com]
> > >
> > > Hello.
> > >
> > > A strong goal of XForms integration with XHTML 2.0, and the
> > > XHTML Working
> > > Group asked that we avoid hyphens and use only lowercase
> > > letters for element
> > > and attribute names, which rules out both "selectOne" and
> > > "select-one".
> >
> > Ok. So what about a 'choice' or 'choose' (compare with 'select')?
> >
> > >
> > > The all lower-case "selectone" is difficult to read in
> > > English, as it would
> > > be pronounced "selec-tone", and is indeed used as such in
> > at least one
> > > trademark (http://www.com-spec.com/selectone/).
> >
> > I see.
> >
> > >
> > > I don't think that trailing numerals in element names are
> > > unusual; see HTML
> > > <h1>, <h2>, etc.
> >
> > The <h1>, etc. elements are deprecated in XHTML 2.0 in favour
> > of <section>
> > elements:
> > http://www.w3.org/TR/2002/WD-xhtml2-20020805/mod-text.html#sec_8.18.
> >
> > So, if XForms is going to be integrated with XHTML 2.0 then
> > it's better to
> > avoid old-styled naming.
> >
> > Regards,
> >   Konstantin
> >
> > >
> > > Thank you,
> > > Leigh L. Klotz, Jr.
> > >
> > > -----Original Message-----
> > > From: Piroumian Konstantin [mailto:KPiroumian@protek.com]
> > > Sent: Monday, August 26, 2002 12:21 AM
> > > To: 'www-forms@w3.org'
> > > Subject: Naming: select1 vs. singleSelect
> > >
> > >
> > >
> > > Hi!
> > >
> > > What is the reason of using a name like 'select1' for single choice
> > > selection element?
> > > Don't you think that this kind of name is absolutely unusual
> > > in XML, XSL,
> > > XHTML or HTML worlds? What's wrong with 'selectOne' or
> > > 'singleSelect'/'multiSelect' names? Or maybe 'select-one'
> > > (using XSLT naming
> > > convensions)?
> > >
> > > Regards,
> > >   Konstantin Piroumian
> > >   Ivelin Ivanov
> > > --
> > >   Apache Cocoon: http://xml.apache.org/cocoon
> > >   kpiroumian@apache.org
> > >   ivelin@apache.org
> > >
> >
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: cocoon-dev-unsubscribe@xml.apache.org
> For additional commands, email: cocoon-dev-help@xml.apache.org
>


---------------------------------------------------------------------
To unsubscribe, e-mail: cocoon-dev-unsubscribe@xml.apache.org
For additional commands, email: cocoon-dev-help@xml.apache.org


Mime
View raw message