cocoon-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Stuart Roebuck <stuart.roeb...@adolos.co.uk>
Subject Re: 2.0.3 Release?
Date Fri, 05 Jul 2002 08:50:45 GMT
On Friday, July 5, 2002, at 08:28 am, Klaus Bertram wrote:

> Hi all,
>
> I had seen that Stuart had problems with jdk 1.3
> For me it is doing well on win2000 with  jdk1.3.1_02 and tomcat 4.0.1
> I use the latest cvs versions of the cocoon_2_0_3_branch tag
>
> I use also the mysql driver  mm.mysql-2.0.14-bin.jar and all runns well
>
> Klaus

Yes, it works fine on Mac OS X jdk 1.3.1 as well, but not on our FreeBSD 
server ( - not wanting to duplicate previous stuff, there's a discussion 
of this in Bug report 9701.)

[continued below...]

> At 08:32 05.07.2002, Carsten  wrote:
>> Stuart Roebuck wrote
>>>
>>> Sorry to repost this, but there are a lot of significant fixes in 
>>> 2.0.3
>>> which we need to be able to install on our live server.
>>>
>> Believe me, you are by far not the only one waiting for this release.
>>
>>> I have just tried the latest CVS version of 2.0.3 and it brought our
>>> live server down again with the same Avalon problems as before, I 
>>> assume
>>> that means that the Avalon classes in the current CVS of 2.0.3 are 
>>> still
>>> JVM 1.4 compiled.
>>>
>>> Am I wrong?
>>
>> Yes, they are compiled with 1.4 in 1.2 compatible mode.
>>
>> As I pointed out several times in the last days/weeks (and really get 
>> boring
>> of doing so),
>> we need to fix the 1.4 problems before we can do a 2.0.3 release:
>>
>> 1. We need two distributions and therefore two versions of excalibur
>> 2. We have to fix the "startup order of components" problem which makes
>> currently
>>   the hsqldb unusable with 1.4. This can either be done by addressing 
>> this
>>   problem in excalibur or by removing hsqldb from the cocoon servlet.
>>
>> So, any patches and help is welcome.
>>
>> Carsten

Okay, I don't have a handle on point 2 (nor access to a release build of 
1.4), but I'm fully aware of point 1 and can reproduce the problem more 
easily than I would wish! :-)

I'll have another go at what has failed me in the past - building Avalon 
from source.  If that works I can post some patches to include two sets 
of Avalon binaries in the source with a switch on the build to use the 
appropriate version.

Can I just clarify that there are no additional tricks with Avalon, 
e.g.: To the best of anyone's knowledge, is Cocoon (and Cocoon 2.0.3 in 
particular) compatible with the latest standard Avalon Framework and 
Avalon Excalibur libraries in their totality with nothing added and 
nothing removed?

Stuart.

            Public Key - 1024D/88DD65AF 2001-11-23 Stuart Roebuck (Adolos)
      Key fingerprint = 89D9 E405 F8B1 9B22 0FA2  F2C1 9E57 5AB1 88DD 65AF
-------------------------------------------------------------------------
Stuart Roebuck                                  stuart.roebuck@adolos.com
Systems Architect                             Java, XML, MacOS X, XP, 
etc.
ADOLOS                                           <http://www.adolos.com/>


---------------------------------------------------------------------
To unsubscribe, e-mail: cocoon-dev-unsubscribe@xml.apache.org
For additional commands, email: cocoon-dev-help@xml.apache.org


Mime
View raw message