cocoon-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Bernhard Huber <berni_hu...@a1.net>
Subject Re: Compile problems
Date Thu, 11 Jul 2002 22:57:23 GMT
<snip/>

>D:\projects\xml-cocoon2\build\cocoon\scratchpad\src\org\apache\cocoon\se
>rvlet\CocoonFilterGeneratorImpl.java:128:
>org.apache.cocoon.servlet.CocoonFilterGeneratorImpl should be declared
>abstract; it does not define init(javax.servlet.FilterConfig) in
>org.apache.cocoon.servlet.CocoonFilterGeneratorImpl
>    [javac] public class CocoonFilterGeneratorImpl implements Filter {
>    [javac]        ^
>    [javac] Note: Some input files use or override a deprecated API.
>    [javac] Note: Recompile with -deprecation for details.
>    [javac] 1 error
>
>BUILD FAILED
>  
>
Hm, I thougt I compiled it with servlet 2.3.....
Now I have applied a patch.
The compiling error happens only if you are using servlet 2.3.
build.xml compiles CocoonFilterGeneratorImpl only if servlet2.3 jar
is available.
So I compiled it using servlet2.3 and it compiles without any compiling 
error
bye bernhard



---------------------------------------------------------------------
To unsubscribe, e-mail: cocoon-dev-unsubscribe@xml.apache.org
For additional commands, email: cocoon-dev-help@xml.apache.org


Mime
View raw message