cocoon-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Carsten Ziegeler" <cziege...@s-und-n.de>
Subject RE: [Important]: JDK issues
Date Wed, 26 Jun 2002 13:56:12 GMT

Vadim Gritsenko wrote:
> 
> Ditto. Just make sure that Excalibur is built with appropriate version
> too - it has JDBC code too.
> 
That's the problem I hinted at in my first email. Doing it correctly
we would have to build two versions of excalibur (1.2 compatible and
1.4 compatible) ourselfs! And this is something I really don't want
to do. 
This would result in a real nightmare and which version do we keep in
our CVS/lib directory? 
Can we assure that Excalibur is the only component we have to take
into account?

Now, making our lifes easier I'm in favour of building only a 1.2 
compatible version (excalibur and all other projects are mostly
build with a JDK 1.2 and not JDK 1.4). 

So we could make a binary distribution for 1.2,1.3 and that would even
run with 1.4 except perhaps when it comes to JDBC. So anyone really
requiring JDBC 3.0 has to build Excalibur and Cocoon himself.

Comments?

Carsten

---------------------------------------------------------------------
To unsubscribe, e-mail: cocoon-dev-unsubscribe@xml.apache.org
For additional commands, email: cocoon-dev-help@xml.apache.org


Mime
View raw message