cocoon-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Carsten Ziegeler" <cziege...@s-und-n.de>
Subject RE: [Bug?]: Javadocs and JDK 1.4
Date Fri, 07 Jun 2002 11:15:46 GMT

Carsten Ziegeler wrote:
> 
> Vadim Gritsenko wrote:
> >
> > >
> > > Well, so JDK 1.4 cannot be used for building javadocs...great!
> > >
> > > If someone is interested, there is a easier workaround:
> > > - simply adding the attribute excludepackagenames="**.java" to the
> > javadoc
> > > task
> >
> > And there is no other way? Sounds like jdk bug...
> >
> Yupp.
> 
Ok, I found that this is entered as a valid bug in the jdk bug database, 
but there is a workaround by using the -subpackages parameter.

Unfortunately this parameter does not work with ...guess what.. jdk 1.3.
So I changed the build.xml, put a condition for generating javadocs in it
and now we can build all javadocs with jdk 1.3 or jdk 1.4.

Carsten

---------------------------------------------------------------------
To unsubscribe, e-mail: cocoon-dev-unsubscribe@xml.apache.org
For additional commands, email: cocoon-dev-help@xml.apache.org


Mime
View raw message