cocoon-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Piroumian Konstantin <KPiroum...@protek.com>
Subject RE: [ERROR] Batik libs again contain XML APIs
Date Tue, 11 Jun 2002 10:17:23 GMT
> From: Michael Hartle [mailto:mhartle@hartle-klug.com] 
> Piroumian Konstantin wrote:
> 
> >Hi all!
> >
> >Batik lib in both branches again contain XML APIs that are 
> buggy and cause
> >problems in i18n transformer
> >(org.xml.sax.helpers.AttributesImpl.getIndex()).
> > 
> >Anybody, please, fix this or tell me, if it's Ok to just 
> remove those API
> >files from the archive then commit it again?
> >
> Removing those API files from the archive should be a quick fix, but 
> sending a remark to the batik-dev list and filing a bug with Bugzilla 
> should be done in addition so Batik itself can improve; on batik-dev, 
> people are not that responsive, but don't let yourself be 
> discouraged by 
> that.

I'd do everything you've said if it were a Batik bug, but it's not a bug,
just a packaging problem. While Cocoon uses a separate up-to-date
xml-apis.jar, Batik comes with older classes in one jar archive file.

Ok, I'll remove those files from the archive and recommit again now.

Konstantin

> 
> Best regards,
> 
> Michael Hartle,
> Hartle & Klug GbR
> 
> 
> 
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: cocoon-dev-unsubscribe@xml.apache.org
> For additional commands, email: cocoon-dev-help@xml.apache.org
> 

---------------------------------------------------------------------
To unsubscribe, e-mail: cocoon-dev-unsubscribe@xml.apache.org
For additional commands, email: cocoon-dev-help@xml.apache.org


Mime
View raw message