cocoon-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Diana Shannon <shan...@apache.org>
Subject run.sh/command line issues
Date Sat, 15 Jun 2002 16:48:29 GMT
I am working on a How-To for the command line. To get started, I had to 
deal with a few issues described below.

First of all, I just committed a patch for run.sh which now reflects the 
revised lib directory structure of 2.03 and HEAD. (Note that run.bat 
already reflects the correct directory structure.)

To test, I typed:

./run.sh -help

in both 2.03 and 2.1 branches. This worked on my setup (OSX 10.1, Java 
1.3.1). Please crosscheck on other Unix flavors.

I then performed a command line static build. I simply did a regular 
docs build (./build.sh clean docs), deleted the html files in 
/build/cocoon/docs and then ran

./run.sh -c build/cocoon/documentation -C 
build/cocoon/documentation/cocoon.xconf -d build/cocoon/docs -w 
build/cocoon/work index.html

This worked on 2.03, but it failed on 2.1.

 From the logs, it looks like the context directory flag (-c) is received:

DEBUG   2002-06-15 11:54:21.183 [ ] (): Getting handle to destination 
directory 'build/cocoon/docs'
DEBUG   2002-06-15 11:54:21.365 [ ] (): Getting handle to working 
directory 'build/cocoon/work'
DEBUG   2002-06-15 11:54:21.368 [ ] (): Getting handle to context 
directory 'build/cocoon/documentation'

However, later on in the log, it appears the context is not resolved 
correctly.

DEBUG   2002-06-15 11:55:42.831 [manager ] (): Resolving 'sitemap.xmap' 
with base 'null' in context 'file:/Users/ds/cvs-apps/cvs-HEAD-
c2/xml-cocoon2/'
DEBUG   2002-06-15 11:55:42.833 [manager ] (): Resolved to systemID 
'file:/Users/ds/cvs-apps/cvs-HEAD-c2/xml-cocoon2/sitemap.xmap'
DEBUG   2002-06-15 11:55:42.857 [manager ] (): Making URL from 
file:/Users/ds/cvs-apps/cvs-HEAD-c2/xml-cocoon2/sitemap.xmap
ERROR   2002-06-15 11:55:42.895 [sitemap ] (): Failed to load sitemap 
from file:/Users/ds/cvs-apps/cvs-HEAD-c2/xml-cocoon2/sitemap.xmap
org.apache.cocoon.ResourceNotFoundException: Resource not found.: 
org.apache.excalibur.source.SourceNotFoundException: Resource not found 
file:/Users/ds/cvs-apps/cvs-HEAD-c2/xml-cocoon2/sitemap.xmap

When I changed the path to sitemap file in 
build/cocoon/documentation/cocoon.xconf from
   <sitemap file="sitemap.xmap" check-reload="yes" logger="sitemap"/>

to make it relative to run.sh (still sitting in the root cvs directory)

<sitemap file="build/cocoon/documentation/sitemap.xmap" check-
reload="yes" logger="sitemap"/>

it worked with 2.1.

Should I file this as a bug?

-- Diana


---------------------------------------------------------------------
To unsubscribe, e-mail: cocoon-dev-unsubscribe@xml.apache.org
For additional commands, email: cocoon-dev-help@xml.apache.org


Mime
View raw message