cocoon-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Nicola Ken Barozzi <nicola...@apache.org>
Subject Re: [Important]: JDK issues
Date Wed, 26 Jun 2002 09:01:02 GMT

Carsten Ziegeler wrote:
> Vadim Gritsenko wrote:
> 
>>It's a non-issue comparing to the real issue:
>>
>>1. Compiling with JDK1.4 against JDK1.4's rt.jar gives incompatible with
>>1.3 code (IIRC, StringBuffer.append() issue)
>>2. Compiling with JDK1.4 against JDK1.3's rt.jar gives incompatible with
>>1.4 code (JDBC 3.0 is not in JDK1.3)
>>
>>Where is the exit from this loop?
>>
>>Will compilation with JDK1.4 against JDK1.3's rt.jar but with JDBC 3.0
>>in front of it help?
>>
> 
> 
> Yes, this is much more complicated than it should be. The best solution
> would be to make only source distributions and skip the binary ones :(
> Or to make two binary distributions, one for JDK 1.3 and one for JDK 1.4...

I would say, let's make two binary dists and get over with this.
It seems that there are many more issues than we are aware of.

-- 
Nicola Ken Barozzi                   nicolaken@apache.org
             - verba volant, scripta manent -
    (discussions get forgotten, just code remains)
---------------------------------------------------------------------


---------------------------------------------------------------------
To unsubscribe, e-mail: cocoon-dev-unsubscribe@xml.apache.org
For additional commands, email: cocoon-dev-help@xml.apache.org


Mime
View raw message