cocoon-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From daniel robinson <d...@dnai.com>
Subject Version Hell
Date Thu, 13 Jun 2002 22:51:33 GMT
I was running fine under Tomcat 4.0.3 and Cocoon 2.0.0.  As part of 
migrating to an ISP I needed to switch to c 2.0.2.  so:

I downgraded to Tomcat 3.3.1 (because the install was going to be easier 
and I had had trouble with 4.0.3)
It is working fine, so I installed c 2.0.2
It was ok so I installed my app (I placed the 2.0.2 libs in my lib 
directory and then created a WAR)
I got this error:

java.lang.RuntimeException: No compiler found in your classpath. Make 
sure you added 'tools.jar'
   at 
org.apache.cocoon.components.language.programming.java.Javac.(Javac.java:91) 


I couldn't figure out what was going on as my classpath seems to be fine 
and I haven't changed ANYTHING in my system while I was doing this 
upgrade.  I also attempted to put tools.jar in the common/lib of the the 
tomcat dir and the web-inf/lib of my app.

Of course there is no problem running the cocoon dist. servelet.



Dan


---------------------------------------------------------------------
To unsubscribe, e-mail: cocoon-dev-unsubscribe@xml.apache.org
For additional commands, email: cocoon-dev-help@xml.apache.org


Mime
View raw message