cocoon-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Christian Haul <>
Subject Re: [announce] Extended sitemap variable substitution syntax
Date Tue, 25 Jun 2002 07:28:34 GMT
On 24.Jun.2002 -- 10:51 PM, Sylvain Wallez wrote:
> Hi team,
> The extended sitemap variable substitution syntax based on InputModules 
> is available in HEAD.

Darn, you beat me by half a class! :-) But this way I have at least
understood by and large how the treeprocessor works. Great!

> This new feature means that InputModules will be more widely used, and 
> therefore I'd like to propose some changes in the names they have in the 
> current cocoon.xconf to more meaningfull ones :
> - "request-param" instead of "request" for request parameters,
> - "request-header" instead of "header" for request headers,
> - "request-attr" instead of "attribute" for request attributes,
> - "session-attr" instead of "session" for session attributes.
> Thoughts ?

IMHO the suggested names are too verbose. And since there is e.g. only
the request header confusion is unlikely.


C h r i s t i a n       H a u l
    fingerprint: 99B0 1D9D 7919 644A 4837  7D73 FEF9 6856 335A 9E08

To unsubscribe, e-mail:
For additional commands, email:

View raw message