cocoon-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From bugzi...@apache.org
Subject DO NOT REPLY [Bug 10117] New: - Problem resolving href for XSLT document("")
Date Fri, 21 Jun 2002 14:12:24 GMT
DO NOT REPLY TO THIS EMAIL, BUT PLEASE POST YOUR BUG 
RELATED COMMENTS THROUGH THE WEB INTERFACE AVAILABLE AT
<http://nagoya.apache.org/bugzilla/show_bug.cgi?id=10117>.
ANY REPLY MADE TO THIS MESSAGE WILL NOT BE COLLECTED AND 
INSERTED IN THE BUG DATABASE.

http://nagoya.apache.org/bugzilla/show_bug.cgi?id=10117

Problem resolving href for XSLT document("")

           Summary: Problem resolving href for XSLT document("")
           Product: Cocoon 2
           Version: 2.0.3
          Platform: Other
        OS/Version: Other
            Status: NEW
          Severity: Normal
          Priority: Other
         Component: sitemap components
        AssignedTo: cocoon-dev@xml.apache.org
        ReportedBy: j3322ptm@yahoo.de


I have a <xsl:variable name="foo" select="document('')/*/my:stuff"/> in my
XSLT. The empty URI in there should resolve to the stylesheet itself, by
specification. The implementation in the current XSLTProcessorImpl always
strips the last path component of the base, so that the URI resolves to
the directory where the style sheete resides. Weirdly, there is another attempt
at resolving in the log, this time with href having the same value as base, so
that the problem isn't really obvious. After this, apparently each access to
the variable causes an attempt at resolving href="" again, without a
follow-up, which really slows down processing, but finally the expected output
is produced.
I think the resolve() method should be fixed to resolve to base if href is
empty.

---------------------------------------------------------------------
To unsubscribe, e-mail: cocoon-dev-unsubscribe@xml.apache.org
For additional commands, email: cocoon-dev-help@xml.apache.org


Mime
View raw message