cocoon-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Christopher Watson" <c.wat...@zen.co.uk>
Subject RE: Cocoon 2.0.2 JDK1.4 Tomcat 4.0.4b1 JDBC Connection PoolingDoesn't Work (for me) - any ideas
Date Mon, 06 May 2002 10:03:57 GMT
Dear Spinnerettes,

Every so often I get a reply to my (much earlier) list message about this
subject.

Later follows my reply to the latest one, which someone may want to correct
or complement ...
but it has prompted me to ask again ..

I want to get JDK1.4 and connection pooling working.

1)	Can I?

2)	What CVS (HEAD or 2.0.3) do I need?

3)	Is a 2.0.3 or other dist where this works forthcoming?

Sorry to be a nag.

For completeness, I think Cocoon is marvellous!


My reply .....
==============

I kind of gave up and went back to Cocoon 2.0.1 , Tomcat 4.0.1 and jdk 1.3,
since I've no pressing need to get to jdk1.4 !

There was a recent 'howto jdk1.4' in the users mailing list, in response to
which I asked if connection pooling worked with it but got no response.

Last I saw on the developers list was talk of a forthcoming 2.0.3 release.
There's a branch ready for this on the CVS, but it's not been put into the
dist

You MAY find that the latest (HEAD) CVS works, albeit with perhaps a bit of
judicious editing of EsqlConnection.java to get it co compile.
(I.E. Just take the /* */ to uncomment the JDBC3 specific stuff)

Also, in 2.0.2 there was a bug in AbstractValidatorAction.java (Thanks Vadim
for helping me with this bit! ) so get that from the CVS -

Frankly, I can't completely remember how my last try with jdk1.4 worked. I
think ESQL Connection Pooling was OK !
But going to whatever the CVS version I last tried had unconnected
side-effects for what I had done, which, although probably more correct,
would have meant me changing what I had done ...

(Aggregation on 2.0.1 with a missing map:part URI would just leave the
missing part out of the aggregate,
on whatever CVS it was I tried with jdk1.4, it did a 404 resource not found)

I'm going to forward this to the user and dev lists since there's been
nothing about progress on this for a while.

I'll change your name in case you don't want it

Sorry I can't be of more immediate help

Christopher


Original Message read :

> I recently downloaded the cocoon 2.0.2 from the apache web site. I have
the same problem of all the people trying to build Cocoon on the Java 1.4.
The only diference: I am using Tomcat 4.0.3

> I saw also some comments about remove the Esql files. But I will need SQL
connection to Firebird or PostgreSQL.

> I review also all the mailing list and it appears nobody had resolved this
problem.

> Please tell me if we can do something to get working Cocoon2.



---------------------------------------------------------------------
To unsubscribe, e-mail: cocoon-dev-unsubscribe@xml.apache.org
For additional commands, email: cocoon-dev-help@xml.apache.org


Mime
View raw message