cocoon-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Nicola Ken Barozzi" <nicola...@apache.org>
Subject Re: [VOTE] new switch-style selector
Date Tue, 16 Apr 2002 11:47:37 GMT
From: "Sylvain Wallez" <sylvain.wallez@anyware-tech.com>

> Hi team,
> 
> Marcus Crafter proposed a while ago a new style of Selector that would 
> allow to factorize some common computation for all <map:when> cases 
> instead of starting from scratch a each case as it is today. This is 
> especially useful when the data that has to be tested is costly to 
> obtain compared to the time of the actual test (e.g. select on a user 
> role that is fetched in a database).
> 
> All this is decribed in 
> http://marc.theaimsgroup.com/?l=xml-cocoon-dev&m=101619559107566&w=4 and 
> http://nagoya.apache.org/bugzilla/show_bug.cgi?id=7244
> 
> Marcus originally called it "ContextualizableSelector", but this seemed 
> inappropriate since there are already many Context objects around in 
> Cocoon. So a better name came which was "SwitchStyleSelector" for its 
> analogy with the switch construct in Java, whereas the current Selector 
> is more analogous to if/else-if constructs.
> 
> So there are two questions :
> 
> - do you want this new style of selector ?
> +1

+1

> - do you have a better name than "SwitchStyleSelector" ?
> I personally don't have ;)

Switcher

-- 
Nicola Ken Barozzi                   nicolaken@apache.org
            - verba volant, scripta manent -
   (discussions get forgotten, just code remains)
---------------------------------------------------------------------


---------------------------------------------------------------------
To unsubscribe, e-mail: cocoon-dev-unsubscribe@xml.apache.org
For additional commands, email: cocoon-dev-help@xml.apache.org


Mime
View raw message