cocoon-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Steven Noels" <stev...@outerthought.org>
Subject RE: [GUMP] Build Failure - Cocoon2
Date Sun, 24 Mar 2002 07:03:22 GMT
Vadim wrote:

> > webapp:
> > [manifest-tool] Writing: ./build/cocoon/webapp/WEB-INF/Manifest.mf
> >
> > BUILD FAILED
> >
> > java.lang.NullPointerException
> >         at ManifestToolTask.process(Unknown Source)
>
> Do me a favor: delete tools/anttasks/*, update CVS, try again.

Hm. This is perhaps a borderline scenario but I found the reason.
Remember I was using "build webapp", *without* the
"-Dinclude.webapp.libs=true" property setting included on the
commandline (nor in %ANT_OPTS%), however.

Doing this, a 'lib' directory containing all the required jars is not
created, still ManifestToolTask wants to traverse that directory to
build Manifest.mf

Upon accessing the unexisting 'lib' directory, ManifestToolTask fails.
When creating the directory manually inside the
build/cocoon/webapp/WEB-INF directory prior to building, all goes well.

If this is not a borderline scenario (not sure), some additional
checking should be done in ManifestToolTask, I guess. I was just using
"build webapp" to quickly check if my fresh check-out of Cocoon CVS was
OK.

</Steven>


---------------------------------------------------------------------
To unsubscribe, e-mail: cocoon-dev-unsubscribe@xml.apache.org
For additional commands, email: cocoon-dev-help@xml.apache.org


Mime
View raw message