cocoon-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Christian Zoffoli <czoff...@xmerlin.org>
Subject Re: BUG in RequestGenerator ?
Date Sat, 23 Mar 2002 15:19:26 GMT
Jeremy Quinn wrote:
> 
[ cut]
> 
> what does the update-user_form_xupdate.xsl stylesheet look like?
> 
> I found I had to do some pretty strange stuff to get mine to work () see:
> xml-cocoon2/src/scratchpad/webapp/mount/editor/editor/stylesheets/request2editor.xsl
> 
> I had to end up declaring the request namespace prefix, and matching with
> it, even though the request is generated using a default namespace, not a
> prefixed one.


thanks to your example, now it works fine :))



> 
> >I obtain the following error message 'XML Parsing Error: no element
> >found'
> >
> >
> >Why?
> 
> Maybe your XSLT is not copying anything.
> 
> Try putting a logger either side:
> 
> <map:match pattern="test2.xml">
>   <map:generate type="request"/>
> 
>         <map:transform type="log">
>                 <map:parameter name="logfile" value="before.log"/>
>                 <map:parameter name="append" value="no"/>
>         </map:transform>
> 
>   <map:transform src="stylesheets/update-user_form_xupdate.xsl" />
> 
>         <map:transform type="log">
>                 <map:parameter name="logfile" value="before.log"/>
>                 <map:parameter name="append" value="no"/>
>         </map:transform>
> 
>   <map:serialize type="xml"/>
> </map:match>
> 


...logger doesn't produce any file ...it's a bug or I have missed
something ?


Christian

---------------------------------------------------------------------
To unsubscribe, e-mail: cocoon-dev-unsubscribe@xml.apache.org
For additional commands, email: cocoon-dev-help@xml.apache.org


Mime
View raw message