cocoon-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Sylvain Wallez <sylvain.wal...@anyware-tech.com>
Subject Running Cocoon on non-compliant servlet engines
Date Wed, 20 Mar 2002 13:21:48 GMT
Hi folks,

The project I'm currently working on requires Cocoon to run on a 2-years 
old Netscape Enterprise server 4.1, which has the servlet 2.2 classes 
but doesn't implement them correctly : no context directory, no 
classloader for WEB-INF, funky resolution of context resources, etc.

So I wrote a BootstrapServlet that sets up a servlet-2.2 compliant 
ServletContext and ClassLoader and uses this environment to create the 
CocoonServlet to which it delegates request handling. And now Cocoon 
runs smoothly !

I guess this could also be used for other "legacy" engines still living 
out there. Are people interested in this ? If yes, I can add it to the 
scratchpad in CVS. Or we could even include it in the soon-to-come 2.0.2 
(Carsten ?).

<shameless-plug>
For the same project, I also wrote the BlobSource (see 
http://www.mail-archive.com/cocoon-dev@xml.apache.org/msg12945.html) for 
which I had no feedback up to now. Nobody interested in this ?
</shameless-plug>

Cheers,
Sylvain

-- 
Sylvain Wallez
 Anyware Technologies                  Apache Cocoon
 http://www.anyware-tech.com           mailto:sylvain@apache.org



---------------------------------------------------------------------
To unsubscribe, e-mail: cocoon-dev-unsubscribe@xml.apache.org
For additional commands, email: cocoon-dev-help@xml.apache.org


Mime
View raw message