cocoon-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From bugzi...@apache.org
Subject DO NOT REPLY [Bug 7573] New: - load and save commands don't work in sunShine createcontext
Date Thu, 28 Mar 2002 13:11:37 GMT
DO NOT REPLY TO THIS EMAIL, BUT PLEASE POST YOUR BUG 
RELATED COMMENTS THROUGH THE WEB INTERFACE AVAILABLE AT
<http://nagoya.apache.org/bugzilla/show_bug.cgi?id=7573>.
ANY REPLY MADE TO THIS MESSAGE WILL NOT BE COLLECTED AND 
INSERTED IN THE BUG DATABASE.

http://nagoya.apache.org/bugzilla/show_bug.cgi?id=7573

load and save commands don't work in sunShine createcontext

           Summary: load and save commands don't work in sunShine
                    createcontext
           Product: Cocoon 2
           Version: Current CVS
          Platform: PC
        OS/Version: Windows NT/2K
            Status: NEW
          Severity: Normal
          Priority: Other
         Component: sitemap components
        AssignedTo: cocoon-dev@xml.apache.org
        ReportedBy: bert@vankets.com


The load and save commands don't work in the sunShine createContext tag.  
Looking in the sunshinePreTransformer.java file I saw that the loads and save 
constants are initialized in reverse.

    public static final String CREATECONTEXT_SAVE_ATTRIBUTE = "load"; // 
optional
    public static final String CREATECONTEXT_LOAD_ATTRIBUTE = "save"; // 
optional

Must be replaced with
    public static final String CREATECONTEXT_SAVE_ATTRIBUTE = "save"; // 
optional
    public static final String CREATECONTEXT_LOAD_ATTRIBUTE = "load"; // 
optional

I tested the change and everything works as it should.

---------------------------------------------------------------------
To unsubscribe, e-mail: cocoon-dev-unsubscribe@xml.apache.org
For additional commands, email: cocoon-dev-help@xml.apache.org


Mime
View raw message