cocoon-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Malte Vahlenkamp" <Malte.Vahlenk...@bdal.de>
Subject Re: DatabaseAction
Date Fri, 08 Feb 2002 10:29:16 GMT
First of all thanks for your help.

Maybe I got something wrong, but this still doesn't work out for me. now I have tried the
following mapping but the behavior is the same: Insert works well for the first table but
fails for the second table due to a null value in projectid.

-------------------------------------------------- Mapping ------------------------------------------
<table name="PROJECTS">
    <keys>
      		<key param="ProjectId" dbcol="projectid" type="int" mode="manual"/>
    </keys>
    <values>
      <value param="ProjectName" dbcol="projectname" type="string"/>
      <value param="UserId" dbcol="userid" type="string"/>
    </values>  		                      	              
  </table>
  
  <table name="USERPROJECTS">	    	      		    
    <keys>      		
    	<key param="ProjectId" request-attribute-name="org.apache.cocoon.acting.AbstractDatabaseAction:ProjectId"
dbcol="projectid" type="int" mode="request-attribute"/>
    </keys>
    <values>      	      					    	
    	<value param="UserId" dbcol="userid" type="int"/>
    </values>    
  </table>      
-------------------------------------------------------------------------------------------------------------

Any comments are appreciated.

Thanks for your time

 Malte


>AFAIK Database Action sets request attributes with the following
>naming scheme

>"org.apache.cocoon.acting.AbstractDatabaseAction:"+key

>so you'd need to read from
>org.apache.cocoon.acting.AbstractDatabaseAction:ProjectId and hope
>that there's no request parameter of that name because it will have
>precedence. 

>Although still not prime time (helper handling needs complete redo)
>you might want to check out the ModularDatabaseActions from the
>scratchpad directory. I wouldn't advise using them for mission
>critical work right now because they will change a bit before they
>will migrate to the main trunk but it might still be worth a look.
>Note that their descriptor format differs from the above.

>BTW: one closing tag </table> seems to be misplaced above.

>	Chris.



---------------------------------------------------------------------
To unsubscribe, e-mail: cocoon-dev-unsubscribe@xml.apache.org
For additional commands, email: cocoon-dev-help@xml.apache.org


Mime
View raw message