cocoon-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Donald Ball <>
Subject RE: xsp engine hangs after upgrading to 2.0.1
Date Wed, 27 Feb 2002 22:11:07 GMT
On Wed, 27 Feb 2002, Vadim Gritsenko wrote:

> > it's running on an nt box, jdk-1.3.1, tomcat-4.0.2. any suggestions?
> 4.0.2? Did you make Cocoon work with 4.0.2? I've seen only negative
> responses about this pair.

cocoon-2.0.0 works without problem in tomcat-4.0.2 after you do one little
thing. you have to copy xml-apis.jar into tomcat's 'lib' directory or else
it fails trying to load some JAXP class, i can't remember which offhand,
some sort of Resolver in the trax api i think. i can post the full strack
trace if it would be helpful. looks like something is trying to use the
wrong classloader?

the cocoon-2.0.1 sample webapp seems to work fine, but the custom webapp
in question fails; at least, its xsp pages fail.

> > (apologies if this belongs on the users list, but i thought the active
> > developers would be interested to know of problems upgrading. the
> webapp
> > does work fine with 2.0.0)
> Just for a case:

we'll give tomcat-4.0.1 a whirl. thanks.

- donald

To unsubscribe, e-mail:
For additional commands, email:

View raw message