cocoon-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Tsui, Alban" <Alban.T...@COGNOS.com>
Subject xi:include problem in xsp?
Date Thu, 28 Feb 2002 13:33:47 GMT

> Considering the following constructs in an xsp page:
> 
> <xsp:element name="xi:include"><xsp:attribute
> name="href">barstyle0.xml</xsp:attribute></xsp:element>
> 
> <xi:include><xsp:attribute
> name="href">barstyle0.xml</xsp:attribute></xi:include>
> 
> <xi:include href="barstyle0.xml"/>
> 
> 
> After this xsp, the page is going throught the XInclude transform. 
> 
> The first construct doesn't work at all and the transform doesn't pick it
> up but the last two work... is this a bug? Or have I done something wrong
> in the first one?
> 
> Took me ages to figure out to use the second one for dynamically include
> xml fragment in xsp page.
> 
> 
> Best wishes
> 
> Alban Tsui
> 
> COGNOS * The Leader in Enterprise Business Intelligence *
> http://www.cognos.com
>  Information Delivery Products, London Development Office, UK
> alban.tsui@cognos.com Tel (direct): +44 (0) 20 78395417
> 
> 
This message may contain privileged and/or confidential information.  If you
have received this e-mail in error or are not the intended recipient, you
may not use, copy, disseminate or distribute it; do not open any
attachments, delete it immediately from your system and notify the sender
promptly by e-mail that you have done so.  Thank you.

---------------------------------------------------------------------
To unsubscribe, e-mail: cocoon-dev-unsubscribe@xml.apache.org
For additional commands, email: cocoon-dev-help@xml.apache.org


Mime
View raw message