cocoon-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Martin Holz <h...@fiz-chemie.de>
Subject Re: Endorsed Standards Override Mechanism / Cocoon2 on JDK1.4
Date Fri, 15 Feb 2002 08:22:11 GMT
Hi,

Sam wrote:
> Hi, I tried to build Cocoon 2.0.1 using JDK1.4 on Debian GNU/Linux
> (stable), but I get errors during compile (see below). Should I be using
> cocoon cvs instead?
>
> Sam
>
> compile:
> Copying 27 files to /usr/src/cocoon-2.0.1/build/cocoon/classes
> Compiling with Java 1.4, debug on, optimize off, deprecation off
> Compiling 391 source files to /usr/src/cocoon-2.0.1/build/cocoon/classes
> /usr/src/cocoon-2.0.1/build/cocoon/src/org/apache/cocoon/components/languag
>e/markup/xsp/EsqlConnection.java:22: class
> org.apache.cocoon.components.language.markup.xsp.EsqlConnection must be
> declared abstract. It does not define int getHoldability() from interface
> java.sql.Connection.
> public class EsqlConnection implements Connection {
              ^

This should be solved in CVS. If you look into 2.0.1 source, you will see, 
that the source allready contains the changes in comments. Sun decided to
add methods to the java.sql.Connection interface in java 1.4 instead of 
subclassing it. 

Martin

---------------------------------------------------------------------
To unsubscribe, e-mail: cocoon-dev-unsubscribe@xml.apache.org
For additional commands, email: cocoon-dev-help@xml.apache.org


Mime
View raw message