cocoon-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Alex Kachanov" <a...@intadev.com>
Subject RE: problems using j2sdk1.4.0 rc
Date Wed, 13 Feb 2002 03:12:08 GMT
It looks like this is not the only problem of running Cocoon
under JDK 1.4 



with best wishes
Alexander Kachanov

-----Original Message-----
From: Enke Michael [mailto:Michael.Enke@wincor-nixdorf.com]
Sent: 12 февраля 2002 г. 20:29
To: cocoon-dev@xml.apache.org
Subject: problems using j2sdk1.4.0 rc


Hi people,
I installed version 1.4.0 release candidate from Sun (under Linux)
but cocoon seems to have problems with this.
I recompiled cocoon-2.1-dev.jar
By calling the first page I got the following error:

ProcessingException: Language Exception ...
Note: sun.tools.javac.Main has been deprecated...

and other (may be following) errors:
EsqlConnectionCocoon2() is an abstract class. It can not be instantiated. ...

In components/language/programming/javac/Javac.java
we ask if it is modern (com.sun...) or not (sun...)
But we have only this line (about line 117):
sun.tools.javac.Main compiler = new sun.tools.javac.Main(err, "javac");
Here we don't care about modern or not.

I wrote the compile method as follows:
  public boolean compile() throws IOException {
    ByteArrayOutputStream err = new ByteArrayOutputStream();
    boolean result = false;
    if(modern) {
      com.sun.tools.javac.Main compiler = new com.sun.tools.javac.Main();
      int iresult = compiler.compile(toStringArray(fillArguments(new ArrayList())));
      if(iresult == 0) result = true;
      else result = false;
    }
    else {
      sun.tools.javac.Main compiler = new sun.tools.javac.Main(err, "javac");
      result = compiler.compile(toStringArray(fillArguments(new ArrayList())));
      this.errors = new ByteArrayInputStream(err.toByteArray());
    }
    return result;
  }

But now I get a java.lang.IncompatibleClassChangeError

The error log says that Excalibur also has problems:

FATAL_E (2002-02-12) 11:29.05:470   [core    ]
(Unknown-URI) Unknown-thread/LogKitLogger:
Excalibur could not create any connections.
Examine your settings to make sure they are correct.
Make sure you can connect with the same settings on your machine.

Any suggestions?

Michael

---------------------------------------------------------------------
To unsubscribe, e-mail: cocoon-dev-unsubscribe@xml.apache.org
For additional commands, email: cocoon-dev-help@xml.apache.org


---------------------------------------------------------------------
To unsubscribe, e-mail: cocoon-dev-unsubscribe@xml.apache.org
For additional commands, email: cocoon-dev-help@xml.apache.org


Mime
View raw message