cocoon-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Vadim Gritsenko" <vadim.gritse...@verizon.net>
Subject RE: include problem in xsp?
Date Thu, 28 Feb 2002 15:24:23 GMT
> From: Tsui, Alban [mailto:Alban.Tsui@COGNOS.com]
> 
> > Considering the following constructs in an xsp page:
> >
> > <xsp:element name="xi:include"><xsp:attribute
> > name="href">barstyle0.xml</xsp:attribute></xsp:element>
> >
> > <xi:include><xsp:attribute
> > name="href">barstyle0.xml</xsp:attribute></xi:include>
> >
> > <xi:include href="barstyle0.xml"/>
> >
> >
> > After this xsp, the page is going throught the XInclude transform.
> >
> > The first construct doesn't work at all and the transform doesn't
pick it
> > up but the last two work... is this a bug? Or have I done something
wrong
> > in the first one?

It is called "XML namespaces". You should know that when defining
element, you must have three pieces at place: XML namespace URI, XML
namespace prefix, element name. Take a look at SAX/DOM APIs.

Regarding declaration of XML-namespaced elements in XSP, try:

<xsp:element uri="http://www.w3.org/2001/XInclude" prefix="xi"
name="include">
  <xsp:attribute name="href">barstyle0.xml</xsp:attribute>
</xsp:element>

Vadim

> > Took me ages to figure out to use the second one for dynamically
include
> > xml fragment in xsp page.
> >
> >
> > Best wishes
> >
> > Alban Tsui
> >
> > COGNOS * The Leader in Enterprise Business Intelligence *
> > http://www.cognos.com
> >  Information Delivery Products, London Development Office, UK
> > alban.tsui@cognos.com Tel (direct): +44 (0) 20 78395417
> >


---------------------------------------------------------------------
To unsubscribe, e-mail: cocoon-dev-unsubscribe@xml.apache.org
For additional commands, email: cocoon-dev-help@xml.apache.org


Mime
View raw message