cocoon-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Leo Sutic" <leo.su...@inspireinfrastructure.com>
Subject [Patch] FilesystemQueueImpl.java does not compile with latest Avalon.
Date Thu, 24 Jan 2002 20:36:42 GMT


> From: bugzilla@apache.org [mailto:bugzilla@apache.org]
>
> ------- Additional Comments From g-froehlich@gmx.de  2002-01-24
20:00 -------
> Sorry, but I think you can forget the 2.0 branch when the the 2.01 version
is
> release soon!

2.0.1 is a part of the 2.0 branch, no?

> 2.01 works with the new Avalon relaese well.

Only if your new store service is included. FilesystemQueueImpl will not
compile with Avalon/Excalibur 4.1 (release date: real soon now) as the
PriorityQueue interface changed from 4.0 to 4.1. The 4.1 PriorityQueue
accepts and returns Object, not Comparable as 4.0.

So, unless we stick with Avalon 4.0 for Cocoon 2.0.1, FilesystemQueueImpl
must be patched. I am about to call for a vote regarding upgrade to
Avalon/Framework 4.1.1 and Avalon/Excalibur 4.1 for Cocoon 2.0.1 as soon
as Berin pushes the big red release button for Avalon/Excalibur 4.1.

/LS


---------------------------------------------------------------------
To unsubscribe, e-mail: cocoon-dev-unsubscribe@xml.apache.org
For additional commands, email: cocoon-dev-help@xml.apache.org


Mime
View raw message