cocoon-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Gerhard Froehlich" <>
Subject RE: [VOTE] Add Store.size() method
Date Thu, 31 Jan 2002 20:05:18 GMT

>From: Berin Loritsch []
>Gerhard Froehlich wrote:
>> +1 on this.
>> But for the "normal" FilesystemStore it doesn't make
>> any sense. Should we split the packages?
>> store/persistent
>> store/memory
>> or something else?
>Something else.


>What we are talking about here is the difference between Persistent
>and Transient Storage.
>The Cache implementation is a hybrid (i.e. uses both semantics).
>Therefore both memory and cache would hold to the minimum Store
>interface.  If there is anything to be kept persistently, you would
>extend the Store interface to have a new interface that had that
>guarantee as part of the contract.
>As regards the size() method, we can specify that it will return -1
>if the underlying store does not support that method.
>I think that is the best way in the long run--who knows we may want
>to support it in the future.  Just because we don't need it now, doesn't
>mean we should do development acrobatics to not support it.

Good idea! I cannot think today. I was on a party with
colleagues yesterday and I'm braindead in the moment.

Your proposal would be clean solution and I'm +1 with this!


Me, Ambivalent? Well, yes and no.

To unsubscribe, e-mail:
For additional commands, email:

View raw message