cocoon-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Berin Loritsch <>
Subject Re: [VOTE] Add Store.size() method
Date Thu, 31 Jan 2002 20:05:31 GMT
Berin Loritsch wrote:

> Gerhard Froehlich wrote:
>> +1 on this.
>> But for the "normal" FilesystemStore it doesn't make
>> any sense. Should we split the packages?
>> store/persistent
>> store/memory

Just in case you didn't catch it, +1 from me as well.

>> or something else?
> Something else.
> What we are talking about here is the difference between Persistent
> and Transient Storage.
> The Cache implementation is a hybrid (i.e. uses both semantics).
> Therefore both memory and cache would hold to the minimum Store
> interface.  If there is anything to be kept persistently, you would
> extend the Store interface to have a new interface that had that
> guarantee as part of the contract.
> As regards the size() method, we can specify that it will return -1
> if the underlying store does not support that method.
> I think that is the best way in the long run--who knows we may want
> to support it in the future.  Just because we don't need it now, doesn't
> mean we should do development acrobatics to not support it.


"They that give up essential liberty to obtain a little temporary safety
  deserve neither liberty nor safety."
                 - Benjamin Franklin

To unsubscribe, e-mail:
For additional commands, email:

View raw message