cocoon-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Vadim Gritsenko" <vadim.gritse...@verizon.net>
Subject SHOWSTOPPER: XSPs do not compile...
Date Fri, 25 Jan 2002 05:00:13 GMT
Thanks to Carsten who pointed out to this problem...

I have the major issue with XSP compilation. Here is the test case:

1. Clean work directory
2. Start sevlet engine
3. Access welcome -> search docs -> create index
4. Choose "Create index", hit "create" button
5. Wait
6. Go back to welcome -> dynamic samples -> simple XSP
7. ClassNotFoundException, in the working directory - file
simple_xsp.java with the size of 8 bytes. 

After restarting the servlet engine everything works Ok :(


Can somebody verify this experience? The key point here is:
1. Compile at least one XSP
2. Generate lucene index (I guess this could be emulated by Teleport or
some other web-crawling software)
3. Try to compile another XSP - which is not compiled yet
4. Result - empty file, with several linefeeds.

I tried to track down this issue, found some unreleased parsers,
unrecycled sources, but nothing helped to solve this problem. I'm
completely lost in the deep of the XSP machinery... 

Torsten, is this issue similar to yours? Pls check whether you have
empty generated java files after this ClassNotFoundException exception
or not.


Vadim



---------------------------------------------------------------------
To unsubscribe, e-mail: cocoon-dev-unsubscribe@xml.apache.org
For additional commands, email: cocoon-dev-help@xml.apache.org


Mime
View raw message